5113 C++ Programming Manual: C:/Users/wukeping/Desktop/5113 C++ Directory Reference

5113 C++ Programming Manual
  • 5113 C++
5113 C++ Directory Reference

Files

file JY5113.h
@SectionBegin JY5113 FileHead
Generated by doxygen 1.9.1


5113 C++ Programming Manual: C:/Users/wukeping/Desktop/5113 C++/JY5113.h File Reference

  • 5113 C++
Typedefs | Enumerations | Functions
JY5113.h File Reference

@SectionBegin JY5113 FileHead More...

Typedefs

typedef void * JY5113_DeviceHandle
@SectionEnd JY5113_Device FileHead More...

Enumerations

enum | JY5113_AI_SampleMode { JY5113_AI_Finite = 0x0 , JY5113_AI_Continuous = 0x1 , JY5113_AI_Single = 0x2 }
enum | JY5113_AI_BandWidth { JY5113_AI_BandWidth_39K = 0x0 , JY5113_AI_BandWidth_15K = 0x1 , JY5113_AI_BandWidth_80K = 0x2 }
enum | JY5113_AI_Terminal { JY5113_AI_RSE = 0x0 , JY5113_AI_Diff = 0x1 }
enum | JY5113_AI_TriggerType { JY5113_AI_Immediately = 0x0 , JY5113_AI_Digital = 0x1 , JY5113_AI_Analog = 0x2 , JY5113_AI_Soft = 0x3 }
enum | JY5113_AO_UpdateMode { JY5113_AO_Finite = 0x0 , JY5113_AO_ContinuousWrapping = 0x1 , JY5113_AO_ContinuousNoWrapping = 0x2 , JY5113_AO_Single = 0x3 }
enum | JY5113_TriggerType { JY5113_AO_Immediately = 0x0 , JY5113_AO_Digital = 0x1 , JY5113_AO_Soft = 0x3 }
enum | JY5113_DI_SampleMode { JY5113_DI_Finite = 0x0 , JY5113_DI_Continuous = 0x1 , JY5113_DI_Single = 0x2 }
enum | JY5113_DI_TriggerType { JY5113_DI_Immediately = 0x0 , JY5113_DI_Digital = 0x1 , JY5113_DI_Soft = 0x3 }
enum | JY5113_DO_UpdateMode { JY5113_DO_Finite = 0x0 , JY5113_DO_ContinuousWrapping = 0x1 , JY5113_DO_ContinuousNoWrapping = 0x2 , JY5113_DO_Single = 0x3 }
enum | JY5113_DO_TriggerType { JY5113_DO_Immediately = 0x0 , JY5113_DO_Digital = 0x1 , JY5113_DO_Soft = 0x3 }
enum | JY5113_CI_SampleMode { JY5113_CI_Finite = 0x0 , JY5113_CI_Continuous = 0x1 , JY5113_CI_Single = 0x2 }
enum JY5113_CI_MeasureType {
JY5113_CI_EdgeCount = 0 , JY5113_CI_Measure_FrequencyOrPeriod = 1 , JY5113_CI_Measure_PulseWidth = 2 , JY5113_CI_Measure_SemiPeriod = 3 ,
JY5113_CI_Measure_EdgeSeparation = 4 , JY5113_CI_EncoderX1 = 5 , JY5113_CI_EncoderX2 = 6 , JY5113_CI_EncoderX4 = 7 ,
JY5113_CI_EncoderTwoPulse = 8
}
enum | JY5113_CountDirection { JY5113_CI_Count_Up , JY5113_CI_Count_Down , JY5113_CI_Count_External }
enum | JY5113_CI_SampleClock { JY5113_CI_ImplicitClock , JY5113_CI_InternalClock , JY5113_CI_ExternalClock }
enum | JY5113_CI_CounterEventSignalIdleState { JY5113_CI_CounterEventSignalIdleState_Low = 0 , JY5113_CI_CounterEventSignalIdleState_High = 1 }
enum | JY5113_CI_ValueReturnMode { JY5113_CI_ReturnTwoValue = 0 , JY5113_CI_ReturnOneValue = 1 }
enum | JY5113_LevelState { JY5113_LowLevel = 0 , JY5113_HighLevel = 1 }
enum | JY5113_CI_StartingEdge { JY5113_RisingEdge = 0 , JY5113_FallingEdge = 1 , JY5113_AnyEdge = 2 }
enum JY5113_InputTerminal {
JY5113_PFI0_Input = 0 , JY5113_PFI1_Input = 1 , JY5113_PFI2_Input = 2 , JY5113_PFI3_Input = 3 ,
JY5113_PFI4_Input = 4 , JY5113_PFI5_Input = 5 , JY5113_PFI6_Input = 6 , JY5113_PFI7_Input = 7 ,
JY5113_PFI8_Input = 8 , JY5113_PFI9_Input = 9 , JY5113_PFI10_Input = 10 , JY5113_PFI11_Input = 11 ,
JY5113_PFI12_Input = 12 , JY5113_PFI13_Input = 13 , JY5113_PFI14_Input = 14 , JY5113_PFI15_Input = 15 ,
JY5113_PXI_Trig0_Input = 16 , JY5113_PXI_Trig1_Input = 17 , JY5113_PXI_Trig2_Input = 18 , JY5113_PXI_Trig3_Input = 19 ,
JY5113_PXI_Trig4_Input = 20 , JY5113_PXI_Trig5_Input = 21 , JY5113_PXI_Trig6_Input = 22 , JY5113_PXI_Trig7_Input = 23 ,
JY5113_AI_SampleClock_Input = 24 , JY5113_AO_SampleClock_Input = 25 , JY5113_DI_SampleClock_Input = 26 , JY5113_DO_SampleClock_Input = 27 ,
JY5113_CO_0_Output_Input = 28 , JY5113_CO_1_Output_Input = 29 , JY5113_CO_2_Output_Input = 30 , JY5113_CO_3_Output_Input = 31 ,
JY5113_CIO_100MHz_Input = 32 , JY5113_CIO_5MHz_Input = 33 , JY5113_CIO_100kHz_Input = 34
}
enum | JY5113_CO_OUTMode { JY5113_CO_Finite = 0x0 , JY5113_CO_ContinuousWrapping = 0x1 , JY5113_CO_ContinuousNoWrapping = 0x2 , JY5113_CO_Single = 0x3 }
enum | JY5113_CO_IdleState { JY5113_CO_LowLevel = 0 , JY5113_CO_HighLevel = 1 }
enum | JY5113_CountTimeBase { JY5113_Internal_Timebase_100M = 0x0 , JY5113_Internal_Timebase_5M = 0x1 , JY5113_Internal_Timebase_100K = 0x2 , JY5113_External_Timebase = 0x3 }
enum | JY5113_CIO_TriggerType { JY5113_CIO_Immediately = 0x0 , JY5113_CIO_Digital = 0x1 , JY5113_CIO_Soft = 0x3 }
enum | JY5113_DeviceProperty { JY5113_Independent = 0 , JY5113_MASTER = 1 , JY5113_SLAVE = 3 }
enum | JY5113_OutputCompleteState { JY5113_Zero = 0x0 , JY5113_Hold = 0x1 }
enum | JY5113_TriggerMode { JY5113_StartTrigger = 0x0 , JY5113_ReferenceTrigger = 0x1 }
enum JY5113_DigitalTriggerSource {
JY5113_PFI0 = 0 , JY5113_PFI1 = 1 , JY5113_PFI2 = 2 , JY5113_PFI3 = 3 ,
JY5113_PFI4 = 4 , JY5113_PFI5 = 5 , JY5113_PFI6 = 6 , JY5113_PFI7 = 7 ,
JY5113_PFI8 = 8 , JY5113_PFI9 = 9 , JY5113_PFI10 = 10 , JY5113_PFI11 = 11 ,
JY5113_PFI12 = 12 , JY5113_PFI13 = 13 , JY5113_PFI14 = 14 , JY5113_PFI15 = 15 ,
JY5113_PXI_Trig0 = 16 , JY5113_PXI_Trig1 = 17 , JY5113_PXI_Trig2 = 18 , JY5113_PXI_Trig3 = 19 ,
JY5113_PXI_Trig4 = 20 , JY5113_PXI_Trig5 = 21 , JY5113_PXI_Trig6 = 22 , JY5113_PXI_Trig7 = 23 ,
JY5113_Inter_AI_StartTrig = 24 , JY5113_Inter_AI_ReferenceTrig = 25 , JY5113_Inter_DI_StartTrig = 26 , JY5113_Inter_DI_ReferenceTrig = 27 ,
JY5113_Inter_AO_StartTrig = 28 , JY5113_Inter_DO_StartTrig = 29 , JY5113_Inter_Counter_0_StartTrig = 30 , JY5113_Inter_Counter_1_StartTrig = 31 ,
JY5113_Inter_Counter_2_StartTrig = 32 , JY5113_Inter_Counter_3_StartTrig = 33 , JY5113_Inter_Counter_0_Out = 34 , JY5113_Inter_Counter_1_Out = 35 ,
JY5113_Inter_Counter_2_Out = 36 , JY5113_Inter_Counter_13_Out = 37
}
enum | JY5113_DigitalTriggerEdge { JY5113_Rising = 0x0 , JY5113_Falling = 0x1 }
enum JY5113_AnalogTriggerSource {
JY5113_Channel_0 = 0 , JY5113_Channel_1 = 1 , JY5113_Channel_2 = 2 , JY5113_Channel_3 = 3 ,
JY5113_Channel_4 = 4 , JY5113_Channel_5 = 5 , JY5113_Channel_6 = 6 , JY5113_Channel_7 = 7 ,
JY5113_Channel_8 = 8 , JY5113_Channel_9 = 9 , JY5113_Channel_10 = 10 , JY5113_Channel_11 = 11 ,
JY5113_Channel_12 = 12 , JY5113_Channel_13 = 13 , JY5113_Channel_14 = 14 , JY5113_Channel_15 = 15 ,
JY5113_Channel_16 = 16 , JY5113_Channel_17 = 17 , JY5113_Channel_18 = 18 , JY5113_Channel_19 = 19 ,
JY5113_Channel_20 = 20 , JY5113_Channel_21 = 21 , JY5113_Channel_22 = 22 , JY5113_Channel_23 = 23 ,
JY5113_Channel_24 = 24 , JY5113_Channel_25 = 25 , JY5113_Channel_26 = 26 , JY5113_Channel_27 = 27 ,
JY5113_Channel_28 = 28 , JY5113_Channel_29 = 29 , JY5113_Channel_30 = 30 , JY5113_Channel_31 = 31 ,
JY5113_Channel_32 = 32 , JY5113_Channel_33 = 33 , JY5113_Channel_34 = 34 , JY5113_Channel_35 = 35 ,
JY5113_Channel_36 = 36 , JY5113_Channel_37 = 37 , JY5113_Channel_38 = 38 , JY5113_Channel_39 = 39 ,
JY5113_Channel_40 = 40 , JY5113_Channel_41 = 41 , JY5113_Channel_42 = 42 , JY5113_Channel_43 = 43 ,
JY5113_Channel_44 = 44 , JY5113_Channel_45 = 45 , JY5113_Channel_46 = 46 , JY5113_Channel_47 = 47 ,
JY5113_Channel_48 = 48 , JY5113_Channel_49 = 49 , JY5113_Channel_50 = 50 , JY5113_Channel_51 = 51 ,
JY5113_Channel_52 = 52 , JY5113_Channel_53 = 53 , JY5113_Channel_54 = 54 , JY5113_Channel_55 = 55 ,
JY5113_Channel_56 = 56 , JY5113_Channel_57 = 57 , JY5113_Channel_58 = 58 , JY5113_Channel_59 = 59 ,
JY5113_Channel_60 = 60 , JY5113_Channel_61 = 61 , JY5113_Channel_62 = 62 , JY5113_Channel_63 = 63
}
enum | JY5113_AnalogWindowCondition { JY5113_Entering = 0x0 , JY5113_Leaving = 0x1 }
enum | JY5113_AnalogTriggerEdge { JY5113_RisingSlope = 0x0 , JY5113_FallingSlope = 0x1 }
enum | JY5113_ClockSource { JY5113_InternalClock = 0x0 , JY5113_ExternalClock = 0x1 }
enum | JY5113_ReferenceClock { JY5113_Internal = 0x0 , JY5113_PXIe_Clk100 = 0x1 }
enum JY5113_ExternalClockTerminal {
JY5113_Clock_PFI_0 = 0 , JY5113_Clock_PFI_1 = 1 , JY5113_Clock_PFI_2 = 2 , JY5113_Clock_PFI_3 = 3 ,
JY5113_Clock_PFI_4 = 4 , JY5113_Clock_PFI_5 = 5 , JY5113_Clock_PFI_6 = 6 , JY5113_Clock_PFI_7 = 7 ,
JY5113_Clock_PFI_8 = 8 , JY5113_Clock_PFI_9 = 9 , JY5113_Clock_PFI_10 = 10 , JY5113_Clock_PFI_11 = 11 ,
JY5113_Clock_PFI_12 = 12 , JY5113_Clock_PFI_13 = 13 , JY5113_Clock_PFI_14 = 14 , JY5113_Clock_PFI_15 = 15 ,
JY5113_Clock_PXI_Trig_0 = 16 , JY5113_Clock_PXI_Trig_1 = 17 , JY5113_Clock_PXI_Trig_2 = 18 , JY5113_Clock_PXI_Trig_3 = 19 ,
JY5113_Clock_PXI_Trig_4 = 20 , JY5113_Clock_PXI_Trig_5 = 21 , JY5113_Clock_PXI_Trig_6 = 22 , JY5113_Clock_PXI_Trig_7 = 23 ,
JY5113_Clock_AI_SampleClock = 24 , JY5113_Clock_AO_SampleClock = 25 , JY5113_Clock_DI_SampleClock = 26 , JY5113_Clock_DO_SampleClock = 27 ,
JY5113_Clock_CI_0_SampleClock = 28 , JY5113_Clock_CI_1_SampleClock = 29 , JY5113_Clock_CI_2_SampleClock = 30 , JY5113_Clock_CI_3_SampleClock = 31 ,
JY5113_Clock_CO_0_Output = 32 , JY5113_Clock_CO_1_Output = 33 , JY5113_Clock_CO_2_Output = 34 , JY5113_Clock_CO_3_Output = 35
}
enum JY5113_Signal_Source {
JY5113_Signal_PFI_0 = 0 , JY5113_Signal_PFI_1 = 1 , JY5113_Signal_PFI_2 = 2 , JY5113_Signal_PFI_3 = 3 ,
JY5113_Signal_PFI_4 = 4 , JY5113_Signal_PFI_5 = 5 , JY5113_Signal_PFI_6 = 6 , JY5113_Signal_PFI_7 = 7 ,
JY5113_Signal_PFI_8 = 8 , JY5113_Signal_PFI_9 = 9 , JY5113_Signal_PFI_10 = 10 , JY5113_Signal_PFI_11 = 11 ,
JY5113_Signal_PFI_12 = 12 , JY5113_Signal_PFI_13 = 13 , JY5113_Signal_PFI_14 = 14 , JY5113_Signal_PFI_15 = 15 ,
JY5113_Signal_PXI_Trig_0 = 16 , JY5113_Signal_PXI_Trig_1 = 17 , JY5113_Signal_PXI_Trig_2 = 18 , JY5113_Signal_PXI_Trig_3 = 19 ,
JY5113_Signal_PXI_Trig_4 = 20 , JY5113_Signal_PXI_Trig_5 = 21 , JY5113_Signal_PXI_Trig_6 = 22 , JY5113_Signal_PXI_Trig_7 = 23 ,
JY5113_Signal_AI_StartTrig = 24 , JY5113_Signal_AI_ReferenceTrig = 25 , JY5113_Signal_DI_StartTrig = 26 , JY5113_Signal_DI_ReferenceTrig = 27 ,
JY5113_Signal_AO_StartTrig = 28 , JY5113_Signal_DO_StartTrig = 29 , JY5113_Signal_CIO_0_StartTrig = 30 , JY5113_Signal_CIO_1_StartTrig = 31 ,
JY5113_Signal_CIO_2_StartTrig = 32 , JY5113_Signal_CIO_3_StartTrig = 33 , JY5113_Signal_AI_SampleClock = 34 , JY5113_Signal_AO_SampleClock = 35 ,
JY5113_Signal_DI_SampleClock = 36 , JY5113_Signal_DO_SampleClock = 37 , JY5113_Signal_CI_0_SampleClock = 38 , JY5113_Signal_CI_1_SampleClock = 39 ,
JY5113_Signal_CI_2_SampleClock = 40 , JY5113_Signal_CI_3_SampleClock = 41 , JY5113_Signal_CO_0_Output = 42 , JY5113_Signal_CO_1_Output = 43 ,
JY5113_Signal_CO_2_Output = 44 , JY5113_Signal_CO_3_Output = 45 , JY5113_Signal_CIO_100MHz = 46 , JY5113_Signal_CIO_5MHz = 47 ,
JY5113_Signal_CIO_100kHz = 48
}
enum JY5113_Signal_Destination {
JY5113_PFI0_OUT = 0 , JY5113_PFI1_OUT = 1 , JY5113_PFI2_OUT = 2 , JY5113_PFI3_OUT = 3 ,
JY5113_PFI4_OUT = 4 , JY5113_PFI5_OUT = 5 , JY5113_PFI6_OUT = 6 , JY5113_PFI7_OUT = 7 ,
JY5113_PFI8_OUT = 8 , JY5113_PFI9_OUT = 9 , JY5113_PFI10_OUT = 10 , JY5113_PFI11_OUT = 11 ,
JY5113_PFI12_OUT = 12 , JY5113_PFI13_OUT = 13 , JY5113_PFI14_OUT = 14 , JY5113_PFI15_OUT = 15 ,
JY5113_PXITrig0_OUT = 16 , JY5113_PXITrig1_OUT = 17 , JY5113_PXITrig2_OUT = 18 , JY5113_PXITrig3_OUT = 29 ,
JY5113_PXITrig4_OUT = 20 , JY5113_PXITrig5_OUT = 21 , JY5113_PXITrig6_OUT = 22 , JY5113_PXITrig7_OUT = 23 ,
JY5113_None = 24
}

Functions

JY5113API int STDCALL | JY5113_Open (int slotNumber, JY5113_DeviceHandle *hDevice)
Open the 5113 devices using the slot number or the device serial number. More...
JY5113API int STDCALL | JY5113_OpenByName (const char *cardName, JY5113_DeviceHandle *hDevice)
Open this 5113 devices using the device alias name which is set by JYTEK utility JYDM. More...
JY5113API int STDCALL | JY5113_GetDeviceID (JY5113_DeviceHandle hDevice, int *deviceID)
Obtain the device ID. More...
JY5113API int STDCALL | JY5113_GetDeviceSerialNumber (JY5113_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5113API int STDCALL | JY5113_SetDeviceStatusLed (JY5113_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...
JY5113API int STDCALL | JY5113_Close (JY5113_DeviceHandle hDevice)
Close this 5113 device. More...
JY5113API int STDCALL | JY5113_SignalRouting (JY5113_DeviceHandle hDevice, JY5113_Signal_Source source, JY5113_Signal_Destination destination)
Route a singal from source to destination. More...
JY5113API int STDCALL | JY5113_DisconnectSignalRouting (JY5113_DeviceHandle hDevice, JY5113_Signal_Destination destination)
Disconnect an established routing. More...
JY5113API int STDCALL | JY5113_SetDeviceReferenceClock (JY5113_DeviceHandle hDevice, JY5113_ReferenceClock clkSource)
Set ReferenceClock for the device.There are two ReferenceClock, Internal 25MHz from this device or 100MHz from the PXIe chassis. More...
JY5113API int STDCALL | JY5113_AI_EnableChannel (JY5113_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY5113_AI_Terminal terminal, JY5113_AI_BandWidth bandWidth)
Enable AI channels. More...
JY5113API int STDCALL | JY5113_AI_SetMode (JY5113_DeviceHandle hDevice, JY5113_AI_SampleMode mode)
Set AI sampling mode More...
JY5113API int STDCALL | JY5113_AI_SetSampleRate (JY5113_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. More...
JY5113API int STDCALL | JY5113_AI_SetSamplesToAcquire (JY5113_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set convert rate. More...
JY5113API int STDCALL | JY5113_AI_SetDSMode (JY5113_DeviceHandle hDevice, bool enable)
Set AI DSMode enable.default : disable(false) More...
JY5113API int STDCALL | JY5113_AI_Start (JY5113_DeviceHandle hDevice)
Start AI acquisition. More...
JY5113API int STDCALL | JY5113_AI_ReadData (JY5113_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer. More...
JY5113API int STDCALL | JY5113_AI_Stop (JY5113_DeviceHandle hDevice)
Stop AI acquisition. More...
JY5113API int STDCALL | JY5113_AI_ReadRawData (JY5113_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer. More...
JY5113API int STDCALL | JY5113_AI_SetSampleClock (JY5113_DeviceHandle hDevice, JY5113_ClockSource clockSource, JY5113_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock source. More...
JY5113API int STDCALL | JY5113_AI_ReadSinglePoint (JY5113_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer. More...
JY5113API int STDCALL | JY5113_AI_SetStartTriggerType (JY5113_DeviceHandle hDevice, JY5113_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5113_AI_TriggerType. More...
JY5113API int STDCALL | JY5113_AI_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogWindowStartTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerCondition is defined by enum JY5113_AnalogWindowCondition. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogHysteresisStartTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogEdgeStartTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetReferenceTriggerType (JY5113_DeviceHandle hDevice, JY5113_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5113_AI_TriggerType More...
JY5113API int STDCALL | JY5113_AI_SetDigitalReferenceTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogWindowReferenceTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerCondition is defined by enum JY5113_AnalogWindowCondition. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogHysteresisReferenceTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetAnalogEdgeReferenceTrigger (JY5113_DeviceHandle hDevice, JY5113_AnalogTriggerSource triggerSource, JY5113_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge. More...
JY5113API int STDCALL | JY5113_AI_SetPreTriggerSamples (JY5113_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0. More...
JY5113API int STDCALL | JY5113_AI_SetReTriggerCount (JY5113_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count. More...
JY5113API int STDCALL | JY5113_AI_SendSoftTrigger (JY5113_DeviceHandle hDevice, JY5113_TriggerMode triggerMode)
Send the software trigger signal. More...
JY5113API int STDCALL | JY5113_AI_WaitUntilDone (JY5113_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode. More...
JY5113API int STDCALL | JY5113_AI_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI task buffer status. More...
JY5113API int STDCALL | JY5113_DI_AddLines (JY5113_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DI channels. More...
JY5113API int STDCALL | JY5113_DI_ReadData (JY5113_DeviceHandle hDevice, unsigned short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read DI data. More...
JY5113API int STDCALL | JY5113_DI_ReadSinglePoint (JY5113_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status. More...
JY5113API int STDCALL | JY5113_DI_ReadSinglePoint_U16 (JY5113_DeviceHandle hDevice, unsigned short *readValue)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status. More...
JY5113API int STDCALL | JY5113_DI_SetSampleRate (JY5113_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DI sampling rate. More...
JY5113API int STDCALL | JY5113_DI_SetSampleClock (JY5113_DeviceHandle hDevice, JY5113_ClockSource clockSource, JY5113_ExternalClockTerminal terminal, double expectedRate)
Set DI sampling clock source. More...
JY5113API int STDCALL | JY5113_DI_Start (JY5113_DeviceHandle hDevice)
Start DI acquisition. More...
JY5113API int STDCALL | JY5113_DI_Stop (JY5113_DeviceHandle hDevice)
Stop DI acquisition. More...
JY5113API int STDCALL | JY5113_DI_SetMode (JY5113_DeviceHandle hDevice, JY5113_DI_SampleMode mode)
JY5113API int STDCALL | JY5113_DI_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status. More...
JY5113API int STDCALL | JY5113_DI_SetSamplesToAcquire (JY5113_DeviceHandle hDevice, int samplesToAcquire)
Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples. More...
JY5113API int STDCALL | JY5113_DI_SetStartTriggerType (JY5113_DeviceHandle hDevice, JY5113_DI_TriggerType triggerType)
Set DI start trigger type,the triggerType is defined by enum JY5113_DI_TriggerType More...
JY5113API int STDCALL | JY5113_DI_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set DI digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_DI_SetReferenceTriggerType (JY5113_DeviceHandle hDevice, JY5113_DI_TriggerType triggerType)
Set DI reference trigger type,the triggerType is defined by enum JY5113_DI_TriggerType. More...
JY5113API int STDCALL | JY5113_DI_SetDigitalReferenceTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_DI_SetPreTriggerSamples (JY5113_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set DI pretrigger samples, the samples must greater than 0. More...
JY5113API int STDCALL | JY5113_DI_SendSoftTrigger (JY5113_DeviceHandle hDevice, JY5113_TriggerMode triggerMode)
Send the software trigger signal. More...
JY5113API int STDCALL | JY5113_DI_WaitUntilDone (JY5113_DeviceHandle hDevice, bool *done)
Check if DI acquisition is completed in finite mode. More...
JY5113API int STDCALL | JY5113_DO_AddLines (JY5113_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DO channels More...
JY5113API int STDCALL | JY5113_DO_WriteData (JY5113_DeviceHandle hDevice, unsigned short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
DO write data. More...
JY5113API int STDCALL | JY5113_DO_WriteSinglePoint (JY5113_DeviceHandle hDevice, bool *writeValues, int lineID)
Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5113_DI_AddLines) More...
JY5113API int STDCALL | JY5113_DO_WriteSinglePoint_U16 (JY5113_DeviceHandle hDevice, unsigned short *writeValue)
Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5113_DI_AddLines) More...
JY5113API int STDCALL | JY5113_DO_SetUpdateRate (JY5113_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DO update rate.The update rate is the same for all channels. More...
JY5113API int STDCALL | JY5113_DO_Start (JY5113_DeviceHandle hDevice)
Start digital signal output. More...
JY5113API int STDCALL | JY5113_DO_Stop (JY5113_DeviceHandle hDevice)
Stop digital signal output. More...
JY5113API int STDCALL | JY5113_DO_SetMode (JY5113_DeviceHandle hDevice, JY5113_DO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5113_AO_UpdateMode. More...
JY5113API int STDCALL | JY5113_DO_SetSamplesToUpdate (JY5113_DeviceHandle hDevice, int samplesToUpdate)
Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples. More...
JY5113API int STDCALL | JY5113_DO_SetSampleClock (JY5113_DeviceHandle hDevice, JY5113_ClockSource clockSource, JY5113_ExternalClockTerminal terminal, double expectedRate)
Set DO sampling clock source. More...
JY5113API int STDCALL | JY5113_DO_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DO device buffer status. More...
JY5113API int STDCALL | JY5113_DO_WaitUntilDone (JY5113_DeviceHandle hDevice, bool *done, int timeOut)
Check finite digital signal output is complete. More...
JY5113API int STDCALL | JY5113_DO_SetStartTriggerType (JY5113_DeviceHandle hDevice, JY5113_DO_TriggerType triggerType)
Set DO start trigger type,the triggerType is defined by enum JY5113_DO_TriggerType. More...
JY5113API int STDCALL | JY5113_DO_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set DO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_DO_SendSoftTrigger (JY5113_DeviceHandle hDevice)
Send the software trigger signal. More...
JY5113API int STDCALL | JY5113_DO_SetOutputCompleteState (JY5113_DeviceHandle hDevice, JY5113_OutputCompleteState State)
Set DO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero. More...
JY5113API int STDCALL | JY5113_AO_EnableChannel (JY5113_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels)
Enables AO channels. More...
JY5113API int STDCALL | JY5113_AO_SetUpdateRate (JY5113_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel. More...
JY5113API int STDCALL | JY5113_AO_SetMode (JY5113_DeviceHandle hDevice, JY5113_AO_UpdateMode mode)
Set AO mode, the mode defined by enum JY5113_AO_UpdateMode. More...
JY5113API int STDCALL | JY5113_AO_SetSamplesToUpdate (JY5113_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples. More...
JY5113API int STDCALL | JY5113_AO_Start (JY5113_DeviceHandle hDevice)
Start digital signal output. More...
JY5113API int STDCALL | JY5113_AO_WriteRawData (JY5113_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel. More...
JY5113API int STDCALL | JY5113_AO_WriteData (JY5113_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY5113_AO_EnableChannel. More...
JY5113API int STDCALL | JY5113_AO_Stop (JY5113_DeviceHandle hDevice)
Stop analog signal output. More...
JY5113API int STDCALL | JY5113_AO_SetSampleClock (JY5113_DeviceHandle hDevice, JY5113_ClockSource clockSource, JY5113_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock source. More...
JY5113API int STDCALL | JY5113_AO_WriteRawSinglePoint (JY5113_DeviceHandle hDevice, unsigned short *writeValues, int channelID)
AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel. More...
JY5113API int STDCALL | JY5113_AO_WriteSinglePoint (JY5113_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data. More...
JY5113API int STDCALL | JY5113_AO_SetStartTriggerType (JY5113_DeviceHandle hDevice, JY5113_TriggerType triggerType)
Set AO start trigger type,the triggerType is defined by enum JY5113_AO_TriggerType. More...
JY5113API int STDCALL | JY5113_AO_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_AO_WaitUntilDone (JY5113_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete. More...
JY5113API int STDCALL | JY5113_AO_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO task buffer status. More...
JY5113API int STDCALL | JY5113_AO_SendSoftTrigger (JY5113_DeviceHandle hDevice)
Send the software trigger signal. More...
JY5113API int STDCALL | JY5113_AO_SetOutputCompleteState (JY5113_DeviceHandle hDevice, JY5113_OutputCompleteState State)
Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero. More...
JY5113API int STDCALL | JY5113_CI_EnableChannel (JY5113_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 2 counter,from 0 and 1. More...
JY5113API int STDCALL | JY5113_CI_SetCounterType (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_MeasureType measureType)
Set CI measure type More...
JY5113API int STDCALL | JY5113_CI_SetSignalReverse (JY5113_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal. More...
JY5113API int STDCALL | JY5113_CI_SetCounterParament (JY5113_DeviceHandle hDevice, unsigned int channel, int initCount, JY5113_CountDirection countDirection)
Set CI count parameter More...
JY5113API int STDCALL | JY5113_CI_SetZReloadEnabled (JY5113_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode. More...
JY5113API int STDCALL | JY5113_CI_SetMode (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5113_CI_SampleMode. More...
JY5113API int STDCALL | JY5113_CI_SetSampleClock (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_SampleClock clock, JY5113_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source. More...
JY5113API int STDCALL | JY5113_CI_SetSamplesToAcquire (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M. More...
JY5113API int STDCALL | JY5113_CI_SetEdgeCountEvent (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal More...
JY5113API int STDCALL | JY5113_CI_SetPauseTriggerLevel (JY5113_DeviceHandle hDevice, unsigned int channel, bool enable, JY5113_LevelState pauseTriggerActiveLevel)
Config CI pause trigger. More...
JY5113API int STDCALL | JY5113_CI_SetPauseTriggerTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_InputTerminal pauseTriggerTerminal)
Set CI pause trigger terminal. More...
JY5113API int STDCALL | JY5113_CI_ReadSingleCountValue (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5113_CI_EdgeCount、JY5113_CI_EncoderX1、 JY5113_CI_EncoderX2 、 JY5113_CI_EncoderX4 、JY5113_CI_EncoderTwoPulse. More...
JY5113API int STDCALL | JY5113_CI_ReadSingleMeasureValue (JY5113_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows. More...
JY5113API int STDCALL | JY5113_CI_ReadCountValues (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5113_CI_EdgeCount、JY5113_CI_EncoderX1、 JY5113_CI_EncoderX2 、 JY5113_CI_EncoderX4 、JY5113_CI_EncoderTwoPulse. More...
JY5113API int STDCALL | JY5113_CI_ReadMeasureValues (JY5113_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5113_CI_Measure_EdgeSeparation JY5113_CI_Measure_Pulse JY5113_CI_Measure_Frequency JY5113_CI_Measure_Period for JY5113_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s. More...
JY5113API int STDCALL | JY5113_CI_Start (JY5113_DeviceHandle hDevice, unsigned int channel)
Start Counter input. More...
JY5113API int STDCALL | JY5113_CI_Stop (JY5113_DeviceHandle hDevice, unsigned int channel)
Stop Counter input. More...
JY5113API int STDCALL | JY5113_CI_SetValueReturnMode (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_ValueReturnMode mode)
Config CI return value mode, only for JY5113_CI_Measure_EdgeSeparation type. More...
JY5113API int STDCALL | JY5113_CI_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status. More...
JY5113API int STDCALL | JY5113_CI_SetTimeBase (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CountTimeBase timebaseSrc, JY5113_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CI timebase source More...
JY5113API int STDCALL | JY5113_CI_SetSourceTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_InputTerminal sourceTerminal)
Set source terminal. More...
JY5113API int STDCALL | JY5113_CI_SetGateTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_InputTerminal gateTerminal)
Set gate terminal. More...
JY5113API int STDCALL | JY5113_CI_SetAuxTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_InputTerminal auxTerminal)
Set aux terminal. More...
JY5113API int STDCALL | JY5113_CI_SetOutTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_Signal_Destination outTerminal)
Set out terminal. More...
JY5113API int STDCALL | JY5113_CI_SendSoftTrigger (JY5113_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI. More...
JY5113API int STDCALL | JY5113_CI_SetStartingEdge (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CI_StartingEdge startingEdge)
Set start measure edge. More...
JY5113API int STDCALL | JY5113_CI_SetFirstSampleClock (JY5113_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set first sample clock is ignore. More...
JY5113API int STDCALL | JY5113_CI_SetStartTriggerType (JY5113_DeviceHandle hDevice, int channel, JY5113_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5113_CI_TriggerType. More...
JY5113API int STDCALL | JY5113_CI_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, int channel, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_CO_EnableChannel (JY5113_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel. More...
JY5113API int STDCALL | JY5113_CO_SetOutTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_Signal_Destination outTerminal)
Set out terminal. More...
JY5113API int STDCALL | JY5113_CO_SetCounterParament (JY5113_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5113_CO_IdleState IdleState, double delay)
Set CO parameter. More...
JY5113API int STDCALL | JY5113_CO_SetFrequency (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time. More...
JY5113API int STDCALL | JY5113_CO_WriteData (JY5113_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses. More...
JY5113API int STDCALL | JY5113_CO_CheckBufferStatus (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status. More...
JY5113API int STDCALL | JY5113_CO_CheckCounterStatus (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter status. More...
JY5113API int STDCALL | JY5113_CO_WaitUntilDone (JY5113_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status. More...
JY5113API int STDCALL | JY5113_CO_SetSamplesToUpdate (JY5113_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples. More...
JY5113API int STDCALL | JY5113_CO_Start (JY5113_DeviceHandle hDevice, unsigned int channel)
Start counter output. More...
JY5113API int STDCALL | JY5113_CO_Stop (JY5113_DeviceHandle hDevice, unsigned int channel)
Stop counter output. More...
JY5113API int STDCALL | JY5113_CO_SetPauseTriggerLevel (JY5113_DeviceHandle hDevice, unsigned int channel, bool enable, JY5113_LevelState pauseTriggerActiveLevel)
Config CO pause trigger. More...
JY5113API int STDCALL | JY5113_CO_SetPauseTriggerTerminal (JY5113_DeviceHandle hDevice, int channel, JY5113_InputTerminal pauseTriggerTerminal)
Set CO pause trigger terminal. More...
JY5113API int STDCALL | JY5113_CO_SetTimeBase (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CountTimeBase timebaseSrc, JY5113_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CO timebase source More...
JY5113API int STDCALL | JY5113_CO_SendSoftTrigger (JY5113_DeviceHandle hDevice, int channel)
Send the software trigger signal. More...
JY5113API int STDCALL | JY5113_CO_SetMode (JY5113_DeviceHandle hDevice, unsigned int channel, JY5113_CO_OUTMode mode)
Set counter output mode, the mode defined by enum JY5113_CO_UpdateMode. More...
JY5113API int STDCALL | JY5113_CO_SetStartTriggerType (JY5113_DeviceHandle hDevice, int channel, JY5113_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5113_AI_TriggerType More...
JY5113API int STDCALL | JY5113_CO_SetDigitalStartTrigger (JY5113_DeviceHandle hDevice, int channel, JY5113_DigitalTriggerSource triggerSource, JY5113_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge. More...
JY5113API int STDCALL | JY5113_DisableAICalibration (JY5113_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default enable calibration coefficient More...
JY5113API int STDCALL | JY5113_DisableAOCalibration (JY5113_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default enable calibration coefficient More...
JY5113API int STDCALL | JY5113_SetPFIFilter (JY5113_DeviceHandle hDevice, int line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI More...

Detailed Description

@SectionBegin JY5113 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2022, JYTEK
All rights reserved.
Author
JYTEK
Version
4.1.0
Date
2023-5-10

This header file defines C/C++ API and enums used in the JY5113 driver.

Revision Notes:

Typedef Documentation

◆ JY5113_DeviceHandle

typedef void* JY5113_DeviceHandle

@SectionEnd JY5113_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JY5113_AI_BandWidth

enum JY5113_AI_BandWidth
Enumerator
JY5113_AI_BandWidth_39K
JY5113_AI_BandWidth_15K
JY5113_AI_BandWidth_80K

◆ JY5113_AI_SampleMode

enum JY5113_AI_SampleMode
Enumerator
JY5113_AI_Finite
JY5113_AI_Continuous
JY5113_AI_Single

◆ JY5113_AI_Terminal

enum JY5113_AI_Terminal
Enumerator
JY5113_AI_RSE
JY5113_AI_Diff

◆ JY5113_AI_TriggerType

enum JY5113_AI_TriggerType
Enumerator
JY5113_AI_Immediately
JY5113_AI_Digital
JY5113_AI_Analog
JY5113_AI_Soft

◆ JY5113_AnalogTriggerEdge

enum JY5113_AnalogTriggerEdge
Enumerator
JY5113_RisingSlope
JY5113_FallingSlope

◆ JY5113_AnalogTriggerSource

enum JY5113_AnalogTriggerSource
Enumerator
JY5113_Channel_0
JY5113_Channel_1
JY5113_Channel_2
JY5113_Channel_3
JY5113_Channel_4
JY5113_Channel_5
JY5113_Channel_6
JY5113_Channel_7
JY5113_Channel_8
JY5113_Channel_9
JY5113_Channel_10
JY5113_Channel_11
JY5113_Channel_12
JY5113_Channel_13
JY5113_Channel_14
JY5113_Channel_15
JY5113_Channel_16
JY5113_Channel_17
JY5113_Channel_18
JY5113_Channel_19
JY5113_Channel_20
JY5113_Channel_21
JY5113_Channel_22
JY5113_Channel_23
JY5113_Channel_24
JY5113_Channel_25
JY5113_Channel_26
JY5113_Channel_27
JY5113_Channel_28
JY5113_Channel_29
JY5113_Channel_30
JY5113_Channel_31
JY5113_Channel_32
JY5113_Channel_33
JY5113_Channel_34
JY5113_Channel_35
JY5113_Channel_36
JY5113_Channel_37
JY5113_Channel_38
JY5113_Channel_39
JY5113_Channel_40
JY5113_Channel_41
JY5113_Channel_42
JY5113_Channel_43
JY5113_Channel_44
JY5113_Channel_45
JY5113_Channel_46
JY5113_Channel_47
JY5113_Channel_48
JY5113_Channel_49
JY5113_Channel_50
JY5113_Channel_51
JY5113_Channel_52
JY5113_Channel_53
JY5113_Channel_54
JY5113_Channel_55
JY5113_Channel_56
JY5113_Channel_57
JY5113_Channel_58
JY5113_Channel_59
JY5113_Channel_60
JY5113_Channel_61
JY5113_Channel_62
JY5113_Channel_63

◆ JY5113_AnalogWindowCondition

enum JY5113_AnalogWindowCondition
Enumerator
JY5113_Entering
JY5113_Leaving

◆ JY5113_AO_UpdateMode

enum JY5113_AO_UpdateMode
Enumerator
JY5113_AO_Finite
JY5113_AO_ContinuousWrapping
JY5113_AO_ContinuousNoWrapping
JY5113_AO_Single

◆ JY5113_CI_CounterEventSignalIdleState

enum JY5113_CI_CounterEventSignalIdleState
Enumerator
JY5113_CI_CounterEventSignalIdleState_Low
JY5113_CI_CounterEventSignalIdleState_High

◆ JY5113_CI_MeasureType

enum JY5113_CI_MeasureType
Enumerator
JY5113_CI_EdgeCount
JY5113_CI_Measure_FrequencyOrPeriod
JY5113_CI_Measure_PulseWidth
JY5113_CI_Measure_SemiPeriod
JY5113_CI_Measure_EdgeSeparation
JY5113_CI_EncoderX1
JY5113_CI_EncoderX2
JY5113_CI_EncoderX4
JY5113_CI_EncoderTwoPulse

◆ JY5113_CI_SampleClock

enum JY5113_CI_SampleClock
Enumerator
JY5113_CI_ImplicitClock
JY5113_CI_InternalClock
JY5113_CI_ExternalClock

◆ JY5113_CI_SampleMode

enum JY5113_CI_SampleMode
Enumerator
JY5113_CI_Finite
JY5113_CI_Continuous
JY5113_CI_Single

◆ JY5113_CI_StartingEdge

enum JY5113_CI_StartingEdge
Enumerator
JY5113_RisingEdge
JY5113_FallingEdge
JY5113_AnyEdge

◆ JY5113_CI_ValueReturnMode

enum JY5113_CI_ValueReturnMode
Enumerator
JY5113_CI_ReturnTwoValue
JY5113_CI_ReturnOneValue

◆ JY5113_CIO_TriggerType

enum JY5113_CIO_TriggerType
Enumerator
JY5113_CIO_Immediately
JY5113_CIO_Digital
JY5113_CIO_Soft

◆ JY5113_ClockSource

enum JY5113_ClockSource
Enumerator
JY5113_InternalClock
JY5113_ExternalClock

◆ JY5113_CO_IdleState

enum JY5113_CO_IdleState
Enumerator
JY5113_CO_LowLevel
JY5113_CO_HighLevel

◆ JY5113_CO_OUTMode

enum JY5113_CO_OUTMode
Enumerator
JY5113_CO_Finite
JY5113_CO_ContinuousWrapping
JY5113_CO_ContinuousNoWrapping
JY5113_CO_Single

◆ JY5113_CountDirection

enum JY5113_CountDirection
Enumerator
JY5113_CI_Count_Up
JY5113_CI_Count_Down
JY5113_CI_Count_External

◆ JY5113_CountTimeBase

enum JY5113_CountTimeBase
Enumerator
JY5113_Internal_Timebase_100M
JY5113_Internal_Timebase_5M
JY5113_Internal_Timebase_100K
JY5113_External_Timebase

◆ JY5113_DeviceProperty

enum JY5113_DeviceProperty
Enumerator
JY5113_Independent
JY5113_MASTER
JY5113_SLAVE

◆ JY5113_DI_SampleMode

enum JY5113_DI_SampleMode
Enumerator
JY5113_DI_Finite
JY5113_DI_Continuous
JY5113_DI_Single

◆ JY5113_DI_TriggerType

enum JY5113_DI_TriggerType
Enumerator
JY5113_DI_Immediately
JY5113_DI_Digital
JY5113_DI_Soft

◆ JY5113_DigitalTriggerEdge

enum JY5113_DigitalTriggerEdge
Enumerator
JY5113_Rising
JY5113_Falling

◆ JY5113_DigitalTriggerSource

enum JY5113_DigitalTriggerSource
Enumerator
JY5113_PFI0
JY5113_PFI1
JY5113_PFI2
JY5113_PFI3
JY5113_PFI4
JY5113_PFI5
JY5113_PFI6
JY5113_PFI7
JY5113_PFI8
JY5113_PFI9
JY5113_PFI10
JY5113_PFI11
JY5113_PFI12
JY5113_PFI13
JY5113_PFI14
JY5113_PFI15
JY5113_PXI_Trig0
JY5113_PXI_Trig1
JY5113_PXI_Trig2
JY5113_PXI_Trig3
JY5113_PXI_Trig4
JY5113_PXI_Trig5
JY5113_PXI_Trig6
JY5113_PXI_Trig7
JY5113_Inter_AI_StartTrig
JY5113_Inter_AI_ReferenceTrig
JY5113_Inter_DI_StartTrig
JY5113_Inter_DI_ReferenceTrig
JY5113_Inter_AO_StartTrig
JY5113_Inter_DO_StartTrig
JY5113_Inter_Counter_0_StartTrig
JY5113_Inter_Counter_1_StartTrig
JY5113_Inter_Counter_2_StartTrig
JY5113_Inter_Counter_3_StartTrig
JY5113_Inter_Counter_0_Out
JY5113_Inter_Counter_1_Out
JY5113_Inter_Counter_2_Out
JY5113_Inter_Counter_13_Out

◆ JY5113_DO_TriggerType

enum JY5113_DO_TriggerType
Enumerator
JY5113_DO_Immediately
JY5113_DO_Digital
JY5113_DO_Soft

◆ JY5113_DO_UpdateMode

enum JY5113_DO_UpdateMode
Enumerator
JY5113_DO_Finite
JY5113_DO_ContinuousWrapping
JY5113_DO_ContinuousNoWrapping
JY5113_DO_Single

◆ JY5113_ExternalClockTerminal

enum JY5113_ExternalClockTerminal
Enumerator
JY5113_Clock_PFI_0
JY5113_Clock_PFI_1
JY5113_Clock_PFI_2
JY5113_Clock_PFI_3
JY5113_Clock_PFI_4
JY5113_Clock_PFI_5
JY5113_Clock_PFI_6
JY5113_Clock_PFI_7
JY5113_Clock_PFI_8
JY5113_Clock_PFI_9
JY5113_Clock_PFI_10
JY5113_Clock_PFI_11
JY5113_Clock_PFI_12
JY5113_Clock_PFI_13
JY5113_Clock_PFI_14
JY5113_Clock_PFI_15
JY5113_Clock_PXI_Trig_0
JY5113_Clock_PXI_Trig_1
JY5113_Clock_PXI_Trig_2
JY5113_Clock_PXI_Trig_3
JY5113_Clock_PXI_Trig_4
JY5113_Clock_PXI_Trig_5
JY5113_Clock_PXI_Trig_6
JY5113_Clock_PXI_Trig_7
JY5113_Clock_AI_SampleClock
JY5113_Clock_AO_SampleClock
JY5113_Clock_DI_SampleClock
JY5113_Clock_DO_SampleClock
JY5113_Clock_CI_0_SampleClock
JY5113_Clock_CI_1_SampleClock
JY5113_Clock_CI_2_SampleClock
JY5113_Clock_CI_3_SampleClock
JY5113_Clock_CO_0_Output
JY5113_Clock_CO_1_Output
JY5113_Clock_CO_2_Output
JY5113_Clock_CO_3_Output

◆ JY5113_InputTerminal

enum JY5113_InputTerminal
Enumerator
JY5113_PFI0_Input
JY5113_PFI1_Input
JY5113_PFI2_Input
JY5113_PFI3_Input
JY5113_PFI4_Input
JY5113_PFI5_Input
JY5113_PFI6_Input
JY5113_PFI7_Input
JY5113_PFI8_Input
JY5113_PFI9_Input
JY5113_PFI10_Input
JY5113_PFI11_Input
JY5113_PFI12_Input
JY5113_PFI13_Input
JY5113_PFI14_Input
JY5113_PFI15_Input
JY5113_PXI_Trig0_Input
JY5113_PXI_Trig1_Input
JY5113_PXI_Trig2_Input
JY5113_PXI_Trig3_Input
JY5113_PXI_Trig4_Input
JY5113_PXI_Trig5_Input
JY5113_PXI_Trig6_Input
JY5113_PXI_Trig7_Input
JY5113_AI_SampleClock_Input
JY5113_AO_SampleClock_Input
JY5113_DI_SampleClock_Input
JY5113_DO_SampleClock_Input
JY5113_CO_0_Output_Input
JY5113_CO_1_Output_Input
JY5113_CO_2_Output_Input
JY5113_CO_3_Output_Input
JY5113_CIO_100MHz_Input
JY5113_CIO_5MHz_Input
JY5113_CIO_100kHz_Input

◆ JY5113_LevelState

enum JY5113_LevelState
Enumerator
JY5113_LowLevel
JY5113_HighLevel

◆ JY5113_OutputCompleteState

enum JY5113_OutputCompleteState
Enumerator
JY5113_Zero
JY5113_Hold

◆ JY5113_ReferenceClock

enum JY5113_ReferenceClock
Enumerator
JY5113_Internal
JY5113_PXIe_Clk100

◆ JY5113_Signal_Destination

enum JY5113_Signal_Destination
Enumerator
JY5113_PFI0_OUT
JY5113_PFI1_OUT
JY5113_PFI2_OUT
JY5113_PFI3_OUT
JY5113_PFI4_OUT
JY5113_PFI5_OUT
JY5113_PFI6_OUT
JY5113_PFI7_OUT
JY5113_PFI8_OUT
JY5113_PFI9_OUT
JY5113_PFI10_OUT
JY5113_PFI11_OUT
JY5113_PFI12_OUT
JY5113_PFI13_OUT
JY5113_PFI14_OUT
JY5113_PFI15_OUT
JY5113_PXITrig0_OUT
JY5113_PXITrig1_OUT
JY5113_PXITrig2_OUT
JY5113_PXITrig3_OUT
JY5113_PXITrig4_OUT
JY5113_PXITrig5_OUT
JY5113_PXITrig6_OUT
JY5113_PXITrig7_OUT
JY5113_None

◆ JY5113_Signal_Source

enum JY5113_Signal_Source
Enumerator
JY5113_Signal_PFI_0
JY5113_Signal_PFI_1
JY5113_Signal_PFI_2
JY5113_Signal_PFI_3
JY5113_Signal_PFI_4
JY5113_Signal_PFI_5
JY5113_Signal_PFI_6
JY5113_Signal_PFI_7
JY5113_Signal_PFI_8
JY5113_Signal_PFI_9
JY5113_Signal_PFI_10
JY5113_Signal_PFI_11
JY5113_Signal_PFI_12
JY5113_Signal_PFI_13
JY5113_Signal_PFI_14
JY5113_Signal_PFI_15
JY5113_Signal_PXI_Trig_0
JY5113_Signal_PXI_Trig_1
JY5113_Signal_PXI_Trig_2
JY5113_Signal_PXI_Trig_3
JY5113_Signal_PXI_Trig_4
JY5113_Signal_PXI_Trig_5
JY5113_Signal_PXI_Trig_6
JY5113_Signal_PXI_Trig_7
JY5113_Signal_AI_StartTrig
JY5113_Signal_AI_ReferenceTrig
JY5113_Signal_DI_StartTrig
JY5113_Signal_DI_ReferenceTrig
JY5113_Signal_AO_StartTrig
JY5113_Signal_DO_StartTrig
JY5113_Signal_CIO_0_StartTrig
JY5113_Signal_CIO_1_StartTrig
JY5113_Signal_CIO_2_StartTrig
JY5113_Signal_CIO_3_StartTrig
JY5113_Signal_AI_SampleClock
JY5113_Signal_AO_SampleClock
JY5113_Signal_DI_SampleClock
JY5113_Signal_DO_SampleClock
JY5113_Signal_CI_0_SampleClock
JY5113_Signal_CI_1_SampleClock
JY5113_Signal_CI_2_SampleClock
JY5113_Signal_CI_3_SampleClock
JY5113_Signal_CO_0_Output
JY5113_Signal_CO_1_Output
JY5113_Signal_CO_2_Output
JY5113_Signal_CO_3_Output
JY5113_Signal_CIO_100MHz
JY5113_Signal_CIO_5MHz
JY5113_Signal_CIO_100kHz

◆ JY5113_TriggerMode

enum JY5113_TriggerMode
Enumerator
JY5113_StartTrigger
JY5113_ReferenceTrigger

◆ JY5113_TriggerType

enum JY5113_TriggerType
Enumerator
JY5113_AO_Immediately
JY5113_AO_Digital
JY5113_AO_Soft

Function Documentation

◆ JY5113_AI_CheckBufferStatus()

JY5113API int STDCALL JY5113_AI_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AI task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_AI_EnableChannel()

JY5113API int STDCALL JY5113_AI_EnableChannel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY5113_AI_Terminal | terminal,
 |  | JY5113_AI_BandWidth | bandWidth
 | ) |  |

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
terminal | array[channelCount] of the terminal configuration defined by enum JY5113_AI_Terminal which can be RSE,or DIFF.
bandWidth | bandwidth for each channel, default 376KHz
Returns
0 if success or other error code

◆ JY5113_AI_ReadData()

JY5113API int STDCALL JY5113_AI_ReadData | ( | JY5113_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5113_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5113_AI_ReadRawData()

JY5113API int STDCALL JY5113_AI_ReadRawData | ( | JY5113_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5113_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5113_AI_ReadSinglePoint()

JY5113API int STDCALL JY5113_AI_ReadSinglePoint | ( | JY5113_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID
 | ) |  |

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5113_AI_SendSoftTrigger()

JY5113API int STDCALL JY5113_AI_SendSoftTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_TriggerMode | triggerMode
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogEdgeReferenceTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogEdgeReferenceTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog trigger conditions.Options:JY5113_RisingSlope,JY5113_FallingSlope
threshold | threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogEdgeStartTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogEdgeStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold
 | ) |  |

Set AI analog edge start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog edge trigger conditions.Options:JY5113_RisingSlope,JY5113_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogHysteresisReferenceTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog trigger conditions.Options:JY5113_RisingSlope,JY5113_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogHysteresisStartTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogHysteresisStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerEdge is defined by enum JY5113_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog hysteresis trigger conditions.Options:JY5113_RisingSlope,JY5113_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogWindowReferenceTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogWindowReferenceTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window reference trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerCondition is defined by enum JY5113_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog window reference trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog window trigger conditions.Options:JY5113_Entering,JY5113_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetAnalogWindowStartTrigger()

JY5113API int STDCALL JY5113_AI_SetAnalogWindowStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AnalogTriggerSource | triggerSource,
 |  | JY5113_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

Set AI analog window start trigger,the triggerSource is defined by enum JY5113_AnalogTriggerSource, the triggerCondition is defined by enum JY5113_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog window trigger conditions.Options:JY5113_Entering,JY5113_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5113_AI_SetDigitalReferenceTrigger()

JY5113API int STDCALL JY5113_AI_SetDigitalReferenceTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger.the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital reference trigger source
triggerEdge | AI digital reference trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5113_AI_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_AI_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5113_AI_SetDSMode()

JY5113API int STDCALL JY5113_AI_SetDSMode | ( | JY5113_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

Set AI DSMode enable.default : disable(false)

Parameters
hDevice | device handle
enable | true: enable oversample; false: disable oversample
Returns
0 if success or other error code

◆ JY5113_AI_SetMode()

JY5113API int STDCALL JY5113_AI_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AI_SampleMode | mode
 | ) |  |

Set AI sampling mode

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5113_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5113_AI_SetPreTriggerSamples()

JY5113API int STDCALL JY5113_AI_SetPreTriggerSamples | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5113_AI_SetReferenceTriggerType()

JY5113API int STDCALL JY5113_AI_SetReferenceTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AI_TriggerType | triggerType
 | ) |  |

Set AI reference trigger type,the triggerType is defined by enum JY5113_AI_TriggerType

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5113_AI_SetReTriggerCount()

JY5113API int STDCALL JY5113_AI_SetReTriggerCount | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount
 | ) |  |

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5113_AI_SetSampleClock()

JY5113API int STDCALL JY5113_AI_SetSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_ClockSource | clockSource,
 |  | JY5113_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AI sampling clock source.

the source of the sampling clock defined by enum JY5113_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external clock terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5113_AI_SetSampleRate()

JY5113API int STDCALL JY5113_AI_SetSampleRate | ( | JY5113_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set sampling rate.

The sampling rate is the same for all channels.the API valid only in sample clock source is Internal.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5113_AI_SetSamplesToAcquire()

JY5113API int STDCALL JY5113_AI_SetSamplesToAcquire | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire
 | ) |  |

Set convert rate.

convertRate is how fast ADC performs the AD conversion. convertRate = channelCount*sampleRate.

Parameters
hDevice | device handle
scanRate | user set convert rate
actualScanRate | actual convert rate set by this device, which may be different from the desired convertRate.
Returns
0 if success or other error code

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 128M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 128M samples / channelCount.
Returns
0 if success or other error code

◆ JY5113_AI_SetStartTriggerType()

JY5113API int STDCALL JY5113_AI_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AI_TriggerType | triggerType
 | ) |  |

Set AI start trigger type,the triggerType is defined by enum JY5113_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5113_AI_Start()

JY5113API int STDCALL JY5113_AI_Start ( JY5113_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AI_Stop()

JY5113API int STDCALL JY5113_AI_Stop ( JY5113_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AI_WaitUntilDone()

JY5113API int STDCALL JY5113_AI_WaitUntilDone | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5113_AO_CheckBufferStatus()

JY5113API int STDCALL JY5113_AO_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check AO task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_AO_EnableChannel()

JY5113API int STDCALL JY5113_AO_EnableChannel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels
 | ) |  |

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5113_AO_SendSoftTrigger()

JY5113API int STDCALL JY5113_AO_SendSoftTrigger ( JY5113_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AO_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_AO_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5113_AO_SetMode()

JY5113API int STDCALL JY5113_AO_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_AO_UpdateMode | mode
 | ) |  |

Set AO mode, the mode defined by enum JY5113_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5113_AO_SetOutputCompleteState()

JY5113API int STDCALL JY5113_AO_SetOutputCompleteState | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_OutputCompleteState | State
 | ) |  |

Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AO_SetSampleClock()

JY5113API int STDCALL JY5113_AO_SetSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_ClockSource | clockSource,
 |  | JY5113_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set AO sampling clock source.

the source of the sampling clock defined by enum JY5113_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JY5113_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5113_AO_SetSamplesToUpdate()

JY5113API int STDCALL JY5113_AO_SetSamplesToUpdate | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate
 | ) |  |

Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if success or other error code

◆ JY5113_AO_SetStartTriggerType()

JY5113API int STDCALL JY5113_AO_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_TriggerType | triggerType
 | ) |  |

Set AO start trigger type,the triggerType is defined by enum JY5113_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY5113_AO_SetUpdateRate()

JY5113API int STDCALL JY5113_AO_SetUpdateRate | ( | JY5113_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate
 | ) |  |

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5113_AO_Start()

JY5113API int STDCALL JY5113_AO_Start ( JY5113_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AO_Stop()

JY5113API int STDCALL JY5113_AO_Stop ( JY5113_DeviceHandle hDevice )

Stop analog signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_AO_WaitUntilDone()

JY5113API int STDCALL JY5113_AO_WaitUntilDone | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JY5113_AO_WriteData()

JY5113API int STDCALL JY5113_AO_WriteData | ( | JY5113_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO writes data.The data is interleaved in the buffer the order defined by JY5113_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5113_AO_WriteRawData()

JY5113API int STDCALL JY5113_AO_WriteRawData | ( | JY5113_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5113_AO_WriteRawSinglePoint()

JY5113API int STDCALL JY5113_AO_WriteRawSinglePoint | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned short * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5113_AO_WriteSinglePoint()

JY5113API int STDCALL JY5113_AO_WriteSinglePoint | ( | JY5113_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID
 | ) |  |

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5113_CI_CheckBufferStatus()

JY5113API int STDCALL JY5113_CI_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_CI_EnableChannel()

JY5113API int STDCALL JY5113_CI_EnableChannel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enables CI channel.There are 2 counter,from 0 and 1.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5113_CI_ReadCountValues()

JY5113API int STDCALL JY5113_CI_ReadCountValues | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the count values, this API is supprot CI Type ：JY5113_CI_EdgeCount、JY5113_CI_EncoderX1、 JY5113_CI_EncoderX2 、 JY5113_CI_EncoderX4 、JY5113_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5113_CI_ReadMeasureValues()

JY5113API int STDCALL JY5113_CI_ReadMeasureValues | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Counter reads the measured values, this API only support CI Type for JY5113_CI_Measure_EdgeSeparation JY5113_CI_Measure_Pulse JY5113_CI_Measure_Frequency JY5113_CI_Measure_Period for JY5113_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY5113_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5113_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5113_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5113_CI_Measure_Period type and JY5113_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5113_CI_ReadSingleCountValue()

JY5113API int STDCALL JY5113_CI_ReadSingleCountValue | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue
 | ) |  |

Counter reads a single count value, this API supports the CI Type: JY5113_CI_EdgeCount、JY5113_CI_EncoderX1、 JY5113_CI_EncoderX2 、 JY5113_CI_EncoderX4 、JY5113_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5113_CI_ReadSingleMeasureValue()

JY5113API int STDCALL JY5113_CI_ReadSingleMeasureValue | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut
 | ) |  |

Reads a single counter measurement as follows.

for JY5113_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5113_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5113_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5113_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5113_CI_SendSoftTrigger()

JY5113API int STDCALL JY5113_CI_SendSoftTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5113_CI_SetAuxTerminal()

JY5113API int STDCALL JY5113_CI_SetAuxTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_InputTerminal | auxTerminal
 | ) |  |

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY5113_CI_SetCounterParament()

JY5113API int STDCALL JY5113_CI_SetCounterParament | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5113_CountDirection | countDirection
 | ) |  |

Set CI count parameter

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5113_CountDirection
Returns
0 if success or other error code

◆ JY5113_CI_SetCounterType()

JY5113API int STDCALL JY5113_CI_SetCounterType | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_MeasureType | measureType
 | ) |  |

Set CI measure type

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5113_CI_MeasureType
Returns
0 if success or other error code

◆ JY5113_CI_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_CI_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CI digital start trigger.the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5113_CI_SetEdgeCountEvent()

JY5113API int STDCALL JY5113_CI_SetEdgeCountEvent | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold
 | ) |  |

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5113_CI_SetFirstSampleClock()

JY5113API int STDCALL JY5113_CI_SetFirstSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore
 | ) |  |

Set first sample clock is ignore.

Parameters
hDevice | device handle
channel | counter input channel
ignore | is ignore first sample clock
Returns
0 if success or other error code

◆ JY5113_CI_SetGateTerminal()

JY5113API int STDCALL JY5113_CI_SetGateTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_InputTerminal | gateTerminal
 | ) |  |

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY5113_CI_SetMode()

JY5113API int STDCALL JY5113_CI_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_SampleMode | mode
 | ) |  |

Set counter input mode, the mode is defined by enum JY5113_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5113_CI_SetOutTerminal()

JY5113API int STDCALL JY5113_CI_SetOutTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_Signal_Destination | outTerminal
 | ) |  |

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5113_CI_SetPauseTriggerLevel()

JY5113API int STDCALL JY5113_CI_SetPauseTriggerLevel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5113_LevelState | pauseTriggerActiveLevel
 | ) |  |

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5113_CI_SetPauseTriggerTerminal()

JY5113API int STDCALL JY5113_CI_SetPauseTriggerTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_InputTerminal | pauseTriggerTerminal
 | ) |  |

Set CI pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY5113_CI_SetSampleClock()

JY5113API int STDCALL JY5113_CI_SetSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_SampleClock | clock,
 |  | JY5113_ExternalClockTerminal | terminal,
 |  | double | rate
 | ) |  |

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY5113_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clock | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY5113_ExternalClockTerminal
rate | clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5113_CI_SetSamplesToAcquire()

JY5113API int STDCALL JY5113_CI_SetSamplesToAcquire | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire
 | ) |  |

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5113_CI_SetSignalReverse()

JY5113API int STDCALL JY5113_CI_SetSignalReverse | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse
 | ) |  |

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5113_CI_SetSourceTerminal()

JY5113API int STDCALL JY5113_CI_SetSourceTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_InputTerminal | sourceTerminal
 | ) |  |

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5113_CI_SetStartingEdge()

JY5113API int STDCALL JY5113_CI_SetStartingEdge | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_StartingEdge | startingEdge
 | ) |  |

Set start measure edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | start measure edge
Returns
0 if success or other error code

◆ JY5113_CI_SetStartTriggerType()

JY5113API int STDCALL JY5113_CI_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_CIO_TriggerType | triggerTyp
 | ) |  |

Set CI start trigger type,the triggerType is defined by enum JY5113_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5113_CI_SetTimeBase()

JY5113API int STDCALL JY5113_CI_SetTimeBase | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CountTimeBase | timebaseSrc,
 |  | JY5113_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set CI timebase source

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY5113_CountTimeBase.Options:JY5113_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5113_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5113_CI_SetValueReturnMode()

JY5113API int STDCALL JY5113_CI_SetValueReturnMode | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CI_ValueReturnMode | mode
 | ) |  |

Config CI return value mode, only for JY5113_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JY5113_CI_SetZReloadEnabled()

JY5113API int STDCALL JY5113_CI_SetZReloadEnabled | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled
 | ) |  |

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5113_CI_Start()

JY5113API int STDCALL JY5113_CI_Start | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5113_CI_Stop()

JY5113API int STDCALL JY5113_CI_Stop | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5113_Close()

JY5113API int STDCALL JY5113_Close ( JY5113_DeviceHandle hDevice )

Close this 5113 device.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_CO_CheckBufferStatus()

JY5113API int STDCALL JY5113_CO_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_CO_CheckCounterStatus()

JY5113API int STDCALL JY5113_CO_CheckCounterStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow
 | ) |  |

Check counter status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | Transfered pulse number
underflow | counter under flow flag
Returns
0 if Success or other error code

◆ JY5113_CO_EnableChannel()

JY5113API int STDCALL JY5113_CO_EnableChannel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5113_CO_SendSoftTrigger()

JY5113API int STDCALL JY5113_CO_SendSoftTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5113_CO_SetCounterParament()

JY5113API int STDCALL JY5113_CO_SetCounterParament | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5113_CO_IdleState | IdleState,
 |  | double | delay
 | ) |  |

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5113_CO_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_CO_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set CO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5113_CO_SetFrequency()

JY5113API int STDCALL JY5113_CO_SetFrequency | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks
 | ) |  |

Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, default:timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, default:timebase is 100MHz.
Returns
0 if success or other error code

◆ JY5113_CO_SetMode()

JY5113API int STDCALL JY5113_CO_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CO_OUTMode | mode
 | ) |  |

Set counter output mode, the mode defined by enum JY5113_CO_UpdateMode.

Parameters
hDevice | device handle
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5113_CO_SetOutTerminal()

JY5113API int STDCALL JY5113_CO_SetOutTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_Signal_Destination | outTerminal
 | ) |  |

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5113_CO_SetPauseTriggerLevel()

JY5113API int STDCALL JY5113_CO_SetPauseTriggerLevel | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5113_LevelState | pauseTriggerActiveLevel
 | ) |  |

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5113_CO_SetPauseTriggerTerminal()

JY5113API int STDCALL JY5113_CO_SetPauseTriggerTerminal | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_InputTerminal | pauseTriggerTerminal
 | ) |  |

Set CO pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY5113_CO_SetSamplesToUpdate()

JY5113API int STDCALL JY5113_CO_SetSamplesToUpdate | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate
 | ) |  |

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5113_CO_SetStartTriggerType()

JY5113API int STDCALL JY5113_CO_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5113_CIO_TriggerType | triggerTyp
 | ) |  |

Set CO start trigger type,the triggerType is defined by enum JY5113_AI_TriggerType

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5113_CO_SetTimeBase()

JY5113API int STDCALL JY5113_CO_SetTimeBase | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5113_CountTimeBase | timebaseSrc,
 |  | JY5113_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq
 | ) |  |

Set CO timebase source

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY5113_CountTimeBase.Options:JY5113_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5113_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5113_CO_Start()

JY5113API int STDCALL JY5113_CO_Start | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5113_CO_Stop()

JY5113API int STDCALL JY5113_CO_Stop | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel
 | ) |  |

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5113_CO_WaitUntilDone()

JY5113API int STDCALL JY5113_CO_WaitUntilDone | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done
 | ) |  |

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5113_CO_WriteData()

JY5113API int STDCALL JY5113_CO_WriteData | ( | JY5113_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5113_DI_AddLines()

JY5113API int STDCALL JY5113_DI_AddLines | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount
 | ) |  |

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing lineIDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5113_DI_CheckBufferStatus()

JY5113API int STDCALL JY5113_DI_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_DI_ReadData()

JY5113API int STDCALL JY5113_DI_ReadData | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read DI data.

The data type is short. There are independent 16 lines independently controlled, from 0 to 15.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

◆ JY5113_DI_ReadSinglePoint()

JY5113API int STDCALL JY5113_DI_ReadSinglePoint | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID
 | ) |  |

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values,when the lineID is - 1, read all enabled row values(enabled channels in function JY5113_DI_AddLines), and store the values in the add order of the line
lineID | line number
Returns
0 if success or other error code

◆ JY5113_DI_ReadSinglePoint_U16()

JY5113API int STDCALL JY5113_DI_ReadSinglePoint_U16 | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned short * | readValue
 | ) |  |

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values,when the lineID is - 1, read all enabled row values(enabled channels in function JY5113_DI_AddLines), and store the values in the add order of the line
lineID | line number
Returns
0 if success or other error code

◆ JY5113_DI_SendSoftTrigger()

JY5113API int STDCALL JY5113_DI_SendSoftTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_TriggerMode | triggerMode
 | ) |  |

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger
Returns
0 if success or other error code

◆ JY5113_DI_SetDigitalReferenceTrigger()

JY5113API int STDCALL JY5113_DI_SetDigitalReferenceTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set AI digital reference trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI reference trigger source
triggerEdge | DI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5113_DI_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_DI_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DI digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5113_DI_SetMode()

JY5113API int STDCALL JY5113_DI_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DI_SampleMode | mode
 | ) |  |

Set DI sampling mode.The mode defined by enum JY5113_DI_SampleMode.

Parameters
hDevice | device handle
mode | DI sampling mode.Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5113_DI_SetPreTriggerSamples()

JY5113API int STDCALL JY5113_DI_SetPreTriggerSamples | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set DI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | DI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5113_DI_SetReferenceTriggerType()

JY5113API int STDCALL JY5113_DI_SetReferenceTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DI_TriggerType | triggerType
 | ) |  |

Set DI reference trigger type,the triggerType is defined by enum JY5113_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI reference trigger type. Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5113_DI_SetSampleClock()

JY5113API int STDCALL JY5113_DI_SetSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_ClockSource | clockSource,
 |  | JY5113_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DI sampling clock source.

the source of the sampling clock defined by enum JY5113_ClockSource If the clock source is external, need to configure external clock terminal and external clock frequency..

Parameters
hDevice | device handle
clockSource | DI sampling clock source
terminal | external clock terminal,defined by enum JY5113_ExternalClockTerminal.
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5113_DI_SetSampleRate()

JY5113API int STDCALL JY5113_DI_SetSampleRate | ( | JY5113_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set DI sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DI sampling rate to be set per channel
actualSampleRate | actually set DI sampling rate.actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5113_DI_SetSamplesToAcquire()

JY5113API int STDCALL JY5113_DI_SetSamplesToAcquire | ( | JY5113_DeviceHandle | hDevice,
 |  | int | samplesToAcquire
 | ) |  |

Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
samplesToAcquire | DI finite samples to acquire for each channelsamples range:1 to 16M samples
Returns
0 if success or other error code

◆ JY5113_DI_SetStartTriggerType()

JY5113API int STDCALL JY5113_DI_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DI_TriggerType | triggerType
 | ) |  |

Set DI start trigger type,the triggerType is defined by enum JY5113_DI_TriggerType

Parameters
hDevice | device handle
triggerType | DI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5113_DI_Start()

JY5113API int STDCALL JY5113_DI_Start ( JY5113_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DI_Stop()

JY5113API int STDCALL JY5113_DI_Stop ( JY5113_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DI_WaitUntilDone()

JY5113API int STDCALL JY5113_DI_WaitUntilDone | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if DI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5113_DisableAICalibration()

JY5113API int STDCALL JY5113_DisableAICalibration | ( | JY5113_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AI calibration coefficient, default enable calibration coefficient

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5113_DisableAOCalibration()

JY5113API int STDCALL JY5113_DisableAOCalibration | ( | JY5113_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

Disable AO calibration coefficient, default enable calibration coefficient

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5113_DisconnectSignalRouting()

JY5113API int STDCALL JY5113_DisconnectSignalRouting | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_Signal_Destination | destination
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5113_Signal_Destination
Returns
0 if success or other error code

◆ JY5113_DO_AddLines()

JY5113API int STDCALL JY5113_DO_AddLines | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount
 | ) |  |

Enabled DO channels

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5113_DO_CheckBufferStatus()

JY5113API int STDCALL JY5113_DO_CheckBufferStatus | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples that the buffer can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5113_DO_SendSoftTrigger()

JY5113API int STDCALL JY5113_DO_SendSoftTrigger ( JY5113_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DO_SetDigitalStartTrigger()

JY5113API int STDCALL JY5113_DO_SetDigitalStartTrigger | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DigitalTriggerSource | triggerSource,
 |  | JY5113_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DO digital start trigger,the triggerSource is defined by enum JY5113_DigitalTriggerSource, the triggerEdge is defined by enum JY5113_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DO digital start trigger source
triggerEdge | DO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5113_DO_SetMode()

JY5113API int STDCALL JY5113_DO_SetMode | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DO_UpdateMode | mode
 | ) |  |

Set digital signal output mode, the mode defined by enum JY5113_AO_UpdateMode.

Parameters
hDevice | device handle
mode | DO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5113_DO_SetOutputCompleteState()

JY5113API int STDCALL JY5113_DO_SetOutputCompleteState | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_OutputCompleteState | State
 | ) |  |

Set DO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DO_SetSampleClock()

JY5113API int STDCALL JY5113_DO_SetSampleClock | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_ClockSource | clockSource,
 |  | JY5113_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DO sampling clock source.

the source of the sampling clock defined by enum JY5113_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | DO sampling clock source
terminal | external terminal, defined by enum JY5113_ExternalClockTerminal
expectedRate | DO external clock frequency

◆ JY5113_DO_SetSamplesToUpdate()

JY5113API int STDCALL JY5113_DO_SetSamplesToUpdate | ( | JY5113_DeviceHandle | hDevice,
 |  | int | samplesToUpdate
 | ) |  |

Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
sampleToUpdate | DO finite output samples, data range:1 to 16M sample.
Returns
0 if success or other error code

◆ JY5113_DO_SetStartTriggerType()

JY5113API int STDCALL JY5113_DO_SetStartTriggerType | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_DO_TriggerType | triggerType
 | ) |  |

Set DO start trigger type,the triggerType is defined by enum JY5113_DO_TriggerType.

Parameters
hDevice | device handle
triggerType | DO start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5113_DO_SetUpdateRate()

JY5113API int STDCALL JY5113_DO_SetUpdateRate | ( | JY5113_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set DO update rate.The update rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DO update rate to be set per channel
actualSampleRate | actually set DO update rate,actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5113_DO_Start()

JY5113API int STDCALL JY5113_DO_Start ( JY5113_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DO_Stop()

JY5113API int STDCALL JY5113_DO_Stop ( JY5113_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5113_DO_WaitUntilDone()

JY5113API int STDCALL JY5113_DO_WaitUntilDone | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check finite digital signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond,this parament not valid in current version
Returns
0 if success or other error code

◆ JY5113_DO_WriteData()

JY5113API int STDCALL JY5113_DO_WriteData | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

DO write data.

The data type is short. There are independent 16 lines independently controlled, from 0 to 15.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualWriteLength | Return value, the actual length of the data write
Returns
0 if success or other error code

◆ JY5113_DO_WriteSinglePoint()

JY5113API int STDCALL JY5113_DO_WriteSinglePoint | ( | JY5113_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID
 | ) |  |

Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5113_DI_AddLines)

Parameters
hDevice | device handle
writeValues | Writes the specified line values, and when the lineID is -1, writes all enabled line values (enabled channels in the JY5113_DO_AddLines function), the values are stored in the order in which the ports were added
lineID | line number
Returns
0 if success or other error code

◆ JY5113_DO_WriteSinglePoint_U16()

JY5113API int STDCALL JY5113_DO_WriteSinglePoint_U16 | ( | JY5113_DeviceHandle | hDevice,
 |  | unsigned short * | writeValue
 | ) |  |

Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5113_DI_AddLines)

Parameters
hDevice | device handle
writeValues | Writes the specified line values, and when the lineID is -1, writes all enabled line values (enabled channels in the JY5113_DO_AddLines function), the values are stored in the order in which the ports were added
lineID | line number
Returns
0 if success or other error code

◆ JY5113_GetDeviceID()

JY5113API int STDCALL JY5113_GetDeviceID | ( | JY5113_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the device ID.

The 5113 is a series of boards. The PXIe-5113 device ID is OxA5113. The PCIe-5113 device ID is OxB5113 The USB-5113 device ID is OxC5113

Parameters
hDevice | device handle
deviceID | device ID
Returns
0 if success or other error code

◆ JY5113_GetDeviceSerialNumber()

JY5113API int STDCALL JY5113_GetDeviceSerialNumber | ( | JY5113_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5113_Open()

JY5113API int STDCALL JY5113_Open | ( | int | slotNumber,
 |  | JY5113_DeviceHandle * | hDevice
 | ) |  |

Open the 5113 devices using the slot number or the device serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The device serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or device serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5113_OpenByName()

JY5113API int STDCALL JY5113_OpenByName | ( | const char * | cardName,
 |  | JY5113_DeviceHandle * | hDevice
 | ) |  |

Open this 5113 devices using the device alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM. Open this 5113 devices using the device alias name which is set by JYTEK utility JYDM. You can change the name using JYDM.

Parameters
cardName | device alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5113_SetDeviceReferenceClock()

JY5113API int STDCALL JY5113_SetDeviceReferenceClock | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_ReferenceClock | clkSource
 | ) |  |

Set ReferenceClock for the device.There are two ReferenceClock, Internal 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports internal 25MHz reference clock.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY5113_ReferenceClock
Returns
0 if success or other error code

◆ JY5113_SetDeviceStatusLed()

JY5113API int STDCALL JY5113_SetDeviceStatusLed | ( | JY5113_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5113_SetPFIFilter()

JY5113API int STDCALL JY5113_SetPFIFilter | ( | JY5113_DeviceHandle | hDevice,
 |  | int | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth
 | ) |  |

Set the filter for the specified PFI

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit:ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JY5113_SignalRouting()

JY5113API int STDCALL JY5113_SignalRouting | ( | JY5113_DeviceHandle | hDevice,
 |  | JY5113_Signal_Source | source,
 |  | JY5113_Signal_Destination | destination
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5113_Signal_Source and JY5113_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5113_Signal_Source
destination | destination of the signal defined by enum JY5113_Signal_Destination
Returns
0 if success or other error code
Generated by doxygen 1.9.1


5113 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 12]
▼ 5113 C++ |
JY5113.h | @SectionBegin JY5113 FileHead


5113 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY5113_AI_Analog : JY5113.h
  • JY5113_AI_BandWidth : JY5113.h
  • JY5113_AI_BandWidth_15K : JY5113.h
  • JY5113_AI_BandWidth_39K : JY5113.h
  • JY5113_AI_BandWidth_80K : JY5113.h
  • JY5113_AI_CheckBufferStatus() : JY5113.h
  • JY5113_AI_Continuous : JY5113.h
  • JY5113_AI_Diff : JY5113.h
  • JY5113_AI_Digital : JY5113.h
  • JY5113_AI_EnableChannel() : JY5113.h
  • JY5113_AI_Finite : JY5113.h
  • JY5113_AI_Immediately : JY5113.h
  • JY5113_AI_ReadData() : JY5113.h
  • JY5113_AI_ReadRawData() : JY5113.h
  • JY5113_AI_ReadSinglePoint() : JY5113.h
  • JY5113_AI_RSE : JY5113.h
  • JY5113_AI_SampleClock_Input : JY5113.h
  • JY5113_AI_SampleMode : JY5113.h
  • JY5113_AI_SendSoftTrigger() : JY5113.h
  • JY5113_AI_SetAnalogEdgeReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogEdgeStartTrigger() : JY5113.h
  • JY5113_AI_SetAnalogHysteresisReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogHysteresisStartTrigger() : JY5113.h
  • JY5113_AI_SetAnalogWindowReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogWindowStartTrigger() : JY5113.h
  • JY5113_AI_SetDigitalReferenceTrigger() : JY5113.h
  • JY5113_AI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_AI_SetDSMode() : JY5113.h
  • JY5113_AI_SetMode() : JY5113.h
  • JY5113_AI_SetPreTriggerSamples() : JY5113.h
  • JY5113_AI_SetReferenceTriggerType() : JY5113.h
  • JY5113_AI_SetReTriggerCount() : JY5113.h
  • JY5113_AI_SetSampleClock() : JY5113.h
  • JY5113_AI_SetSampleRate() : JY5113.h
  • JY5113_AI_SetSamplesToAcquire() : JY5113.h
  • JY5113_AI_SetStartTriggerType() : JY5113.h
  • JY5113_AI_Single : JY5113.h
  • JY5113_AI_Soft : JY5113.h
  • JY5113_AI_Start() : JY5113.h
  • JY5113_AI_Stop() : JY5113.h
  • JY5113_AI_Terminal : JY5113.h
  • JY5113_AI_TriggerType : JY5113.h
  • JY5113_AI_WaitUntilDone() : JY5113.h
  • JY5113_AnalogTriggerEdge : JY5113.h
  • JY5113_AnalogTriggerSource : JY5113.h
  • JY5113_AnalogWindowCondition : JY5113.h
  • JY5113_AnyEdge : JY5113.h
  • JY5113_AO_CheckBufferStatus() : JY5113.h
  • JY5113_AO_ContinuousNoWrapping : JY5113.h
  • JY5113_AO_ContinuousWrapping : JY5113.h
  • JY5113_AO_Digital : JY5113.h
  • JY5113_AO_EnableChannel() : JY5113.h
  • JY5113_AO_Finite : JY5113.h
  • JY5113_AO_Immediately : JY5113.h
  • JY5113_AO_SampleClock_Input : JY5113.h
  • JY5113_AO_SendSoftTrigger() : JY5113.h
  • JY5113_AO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_AO_SetMode() : JY5113.h
  • JY5113_AO_SetOutputCompleteState() : JY5113.h
  • JY5113_AO_SetSampleClock() : JY5113.h
  • JY5113_AO_SetSamplesToUpdate() : JY5113.h
  • JY5113_AO_SetStartTriggerType() : JY5113.h
  • JY5113_AO_SetUpdateRate() : JY5113.h
  • JY5113_AO_Single : JY5113.h
  • JY5113_AO_Soft : JY5113.h
  • JY5113_AO_Start() : JY5113.h
  • JY5113_AO_Stop() : JY5113.h
  • JY5113_AO_UpdateMode : JY5113.h
  • JY5113_AO_WaitUntilDone() : JY5113.h
  • JY5113_AO_WriteData() : JY5113.h
  • JY5113_AO_WriteRawData() : JY5113.h
  • JY5113_AO_WriteRawSinglePoint() : JY5113.h
  • JY5113_AO_WriteSinglePoint() : JY5113.h
  • JY5113_Channel_0 : JY5113.h
  • JY5113_Channel_1 : JY5113.h
  • JY5113_Channel_10 : JY5113.h
  • JY5113_Channel_11 : JY5113.h
  • JY5113_Channel_12 : JY5113.h
  • JY5113_Channel_13 : JY5113.h
  • JY5113_Channel_14 : JY5113.h
  • JY5113_Channel_15 : JY5113.h
  • JY5113_Channel_16 : JY5113.h
  • JY5113_Channel_17 : JY5113.h
  • JY5113_Channel_18 : JY5113.h
  • JY5113_Channel_19 : JY5113.h
  • JY5113_Channel_2 : JY5113.h
  • JY5113_Channel_20 : JY5113.h
  • JY5113_Channel_21 : JY5113.h
  • JY5113_Channel_22 : JY5113.h
  • JY5113_Channel_23 : JY5113.h
  • JY5113_Channel_24 : JY5113.h
  • JY5113_Channel_25 : JY5113.h
  • JY5113_Channel_26 : JY5113.h
  • JY5113_Channel_27 : JY5113.h
  • JY5113_Channel_28 : JY5113.h
  • JY5113_Channel_29 : JY5113.h
  • JY5113_Channel_3 : JY5113.h
  • JY5113_Channel_30 : JY5113.h
  • JY5113_Channel_31 : JY5113.h
  • JY5113_Channel_32 : JY5113.h
  • JY5113_Channel_33 : JY5113.h
  • JY5113_Channel_34 : JY5113.h
  • JY5113_Channel_35 : JY5113.h
  • JY5113_Channel_36 : JY5113.h
  • JY5113_Channel_37 : JY5113.h
  • JY5113_Channel_38 : JY5113.h
  • JY5113_Channel_39 : JY5113.h
  • JY5113_Channel_4 : JY5113.h
  • JY5113_Channel_40 : JY5113.h
  • JY5113_Channel_41 : JY5113.h
  • JY5113_Channel_42 : JY5113.h
  • JY5113_Channel_43 : JY5113.h
  • JY5113_Channel_44 : JY5113.h
  • JY5113_Channel_45 : JY5113.h
  • JY5113_Channel_46 : JY5113.h
  • JY5113_Channel_47 : JY5113.h
  • JY5113_Channel_48 : JY5113.h
  • JY5113_Channel_49 : JY5113.h
  • JY5113_Channel_5 : JY5113.h
  • JY5113_Channel_50 : JY5113.h
  • JY5113_Channel_51 : JY5113.h
  • JY5113_Channel_52 : JY5113.h
  • JY5113_Channel_53 : JY5113.h
  • JY5113_Channel_54 : JY5113.h
  • JY5113_Channel_55 : JY5113.h
  • JY5113_Channel_56 : JY5113.h
  • JY5113_Channel_57 : JY5113.h
  • JY5113_Channel_58 : JY5113.h
  • JY5113_Channel_59 : JY5113.h
  • JY5113_Channel_6 : JY5113.h
  • JY5113_Channel_60 : JY5113.h
  • JY5113_Channel_61 : JY5113.h
  • JY5113_Channel_62 : JY5113.h
  • JY5113_Channel_63 : JY5113.h
  • JY5113_Channel_7 : JY5113.h
  • JY5113_Channel_8 : JY5113.h
  • JY5113_Channel_9 : JY5113.h
  • JY5113_CI_CheckBufferStatus() : JY5113.h
  • JY5113_CI_Continuous : JY5113.h
  • JY5113_CI_Count_Down : JY5113.h
  • JY5113_CI_Count_External : JY5113.h
  • JY5113_CI_Count_Up : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState_High : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState_Low : JY5113.h
  • JY5113_CI_EdgeCount : JY5113.h
  • JY5113_CI_EnableChannel() : JY5113.h
  • JY5113_CI_EncoderTwoPulse : JY5113.h
  • JY5113_CI_EncoderX1 : JY5113.h
  • JY5113_CI_EncoderX2 : JY5113.h
  • JY5113_CI_EncoderX4 : JY5113.h
  • JY5113_CI_ExternalClock : JY5113.h
  • JY5113_CI_Finite : JY5113.h
  • JY5113_CI_ImplicitClock : JY5113.h
  • JY5113_CI_InternalClock : JY5113.h
  • JY5113_CI_Measure_EdgeSeparation : JY5113.h
  • JY5113_CI_Measure_FrequencyOrPeriod : JY5113.h
  • JY5113_CI_Measure_PulseWidth : JY5113.h
  • JY5113_CI_Measure_SemiPeriod : JY5113.h
  • JY5113_CI_MeasureType : JY5113.h
  • JY5113_CI_ReadCountValues() : JY5113.h
  • JY5113_CI_ReadMeasureValues() : JY5113.h
  • JY5113_CI_ReadSingleCountValue() : JY5113.h
  • JY5113_CI_ReadSingleMeasureValue() : JY5113.h
  • JY5113_CI_ReturnOneValue : JY5113.h
  • JY5113_CI_ReturnTwoValue : JY5113.h
  • JY5113_CI_SampleClock : JY5113.h
  • JY5113_CI_SampleMode : JY5113.h
  • JY5113_CI_SendSoftTrigger() : JY5113.h
  • JY5113_CI_SetAuxTerminal() : JY5113.h
  • JY5113_CI_SetCounterParament() : JY5113.h
  • JY5113_CI_SetCounterType() : JY5113.h
  • JY5113_CI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_CI_SetEdgeCountEvent() : JY5113.h
  • JY5113_CI_SetFirstSampleClock() : JY5113.h
  • JY5113_CI_SetGateTerminal() : JY5113.h
  • JY5113_CI_SetMode() : JY5113.h
  • JY5113_CI_SetOutTerminal() : JY5113.h
  • JY5113_CI_SetPauseTriggerLevel() : JY5113.h
  • JY5113_CI_SetPauseTriggerTerminal() : JY5113.h
  • JY5113_CI_SetSampleClock() : JY5113.h
  • JY5113_CI_SetSamplesToAcquire() : JY5113.h
  • JY5113_CI_SetSignalReverse() : JY5113.h
  • JY5113_CI_SetSourceTerminal() : JY5113.h
  • JY5113_CI_SetStartingEdge() : JY5113.h
  • JY5113_CI_SetStartTriggerType() : JY5113.h
  • JY5113_CI_SetTimeBase() : JY5113.h
  • JY5113_CI_SetValueReturnMode() : JY5113.h
  • JY5113_CI_SetZReloadEnabled() : JY5113.h
  • JY5113_CI_Single : JY5113.h
  • JY5113_CI_Start() : JY5113.h
  • JY5113_CI_StartingEdge : JY5113.h
  • JY5113_CI_Stop() : JY5113.h
  • JY5113_CI_ValueReturnMode : JY5113.h
  • JY5113_CIO_100kHz_Input : JY5113.h
  • JY5113_CIO_100MHz_Input : JY5113.h
  • JY5113_CIO_5MHz_Input : JY5113.h
  • JY5113_CIO_Digital : JY5113.h
  • JY5113_CIO_Immediately : JY5113.h
  • JY5113_CIO_Soft : JY5113.h
  • JY5113_CIO_TriggerType : JY5113.h
  • JY5113_Clock_AI_SampleClock : JY5113.h
  • JY5113_Clock_AO_SampleClock : JY5113.h
  • JY5113_Clock_CI_0_SampleClock : JY5113.h
  • JY5113_Clock_CI_1_SampleClock : JY5113.h
  • JY5113_Clock_CI_2_SampleClock : JY5113.h
  • JY5113_Clock_CI_3_SampleClock : JY5113.h
  • JY5113_Clock_CO_0_Output : JY5113.h
  • JY5113_Clock_CO_1_Output : JY5113.h
  • JY5113_Clock_CO_2_Output : JY5113.h
  • JY5113_Clock_CO_3_Output : JY5113.h
  • JY5113_Clock_DI_SampleClock : JY5113.h
  • JY5113_Clock_DO_SampleClock : JY5113.h
  • JY5113_Clock_PFI_0 : JY5113.h
  • JY5113_Clock_PFI_1 : JY5113.h
  • JY5113_Clock_PFI_10 : JY5113.h
  • JY5113_Clock_PFI_11 : JY5113.h
  • JY5113_Clock_PFI_12 : JY5113.h
  • JY5113_Clock_PFI_13 : JY5113.h
  • JY5113_Clock_PFI_14 : JY5113.h
  • JY5113_Clock_PFI_15 : JY5113.h
  • JY5113_Clock_PFI_2 : JY5113.h
  • JY5113_Clock_PFI_3 : JY5113.h
  • JY5113_Clock_PFI_4 : JY5113.h
  • JY5113_Clock_PFI_5 : JY5113.h
  • JY5113_Clock_PFI_6 : JY5113.h
  • JY5113_Clock_PFI_7 : JY5113.h
  • JY5113_Clock_PFI_8 : JY5113.h
  • JY5113_Clock_PFI_9 : JY5113.h
  • JY5113_Clock_PXI_Trig_0 : JY5113.h
  • JY5113_Clock_PXI_Trig_1 : JY5113.h
  • JY5113_Clock_PXI_Trig_2 : JY5113.h
  • JY5113_Clock_PXI_Trig_3 : JY5113.h
  • JY5113_Clock_PXI_Trig_4 : JY5113.h
  • JY5113_Clock_PXI_Trig_5 : JY5113.h
  • JY5113_Clock_PXI_Trig_6 : JY5113.h
  • JY5113_Clock_PXI_Trig_7 : JY5113.h
  • JY5113_ClockSource : JY5113.h
  • JY5113_Close() : JY5113.h
  • JY5113_CO_0_Output_Input : JY5113.h
  • JY5113_CO_1_Output_Input : JY5113.h
  • JY5113_CO_2_Output_Input : JY5113.h
  • JY5113_CO_3_Output_Input : JY5113.h
  • JY5113_CO_CheckBufferStatus() : JY5113.h
  • JY5113_CO_CheckCounterStatus() : JY5113.h
  • JY5113_CO_ContinuousNoWrapping : JY5113.h
  • JY5113_CO_ContinuousWrapping : JY5113.h
  • JY5113_CO_EnableChannel() : JY5113.h
  • JY5113_CO_Finite : JY5113.h
  • JY5113_CO_HighLevel : JY5113.h
  • JY5113_CO_IdleState : JY5113.h
  • JY5113_CO_LowLevel : JY5113.h
  • JY5113_CO_OUTMode : JY5113.h
  • JY5113_CO_SendSoftTrigger() : JY5113.h
  • JY5113_CO_SetCounterParament() : JY5113.h
  • JY5113_CO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_CO_SetFrequency() : JY5113.h
  • JY5113_CO_SetMode() : JY5113.h
  • JY5113_CO_SetOutTerminal() : JY5113.h
  • JY5113_CO_SetPauseTriggerLevel() : JY5113.h
  • JY5113_CO_SetPauseTriggerTerminal() : JY5113.h
  • JY5113_CO_SetSamplesToUpdate() : JY5113.h
  • JY5113_CO_SetStartTriggerType() : JY5113.h
  • JY5113_CO_SetTimeBase() : JY5113.h
  • JY5113_CO_Single : JY5113.h
  • JY5113_CO_Start() : JY5113.h
  • JY5113_CO_Stop() : JY5113.h
  • JY5113_CO_WaitUntilDone() : JY5113.h
  • JY5113_CO_WriteData() : JY5113.h
  • JY5113_CountDirection : JY5113.h
  • JY5113_CountTimeBase : JY5113.h
  • JY5113_DeviceHandle : JY5113.h
  • JY5113_DeviceProperty : JY5113.h
  • JY5113_DI_AddLines() : JY5113.h
  • JY5113_DI_CheckBufferStatus() : JY5113.h
  • JY5113_DI_Continuous : JY5113.h
  • JY5113_DI_Digital : JY5113.h
  • JY5113_DI_Finite : JY5113.h
  • JY5113_DI_Immediately : JY5113.h
  • JY5113_DI_ReadData() : JY5113.h
  • JY5113_DI_ReadSinglePoint() : JY5113.h
  • JY5113_DI_ReadSinglePoint_U16() : JY5113.h
  • JY5113_DI_SampleClock_Input : JY5113.h
  • JY5113_DI_SampleMode : JY5113.h
  • JY5113_DI_SendSoftTrigger() : JY5113.h
  • JY5113_DI_SetDigitalReferenceTrigger() : JY5113.h
  • JY5113_DI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_DI_SetMode() : JY5113.h
  • JY5113_DI_SetPreTriggerSamples() : JY5113.h
  • JY5113_DI_SetReferenceTriggerType() : JY5113.h
  • JY5113_DI_SetSampleClock() : JY5113.h
  • JY5113_DI_SetSampleRate() : JY5113.h
  • JY5113_DI_SetSamplesToAcquire() : JY5113.h
  • JY5113_DI_SetStartTriggerType() : JY5113.h
  • JY5113_DI_Single : JY5113.h
  • JY5113_DI_Soft : JY5113.h
  • JY5113_DI_Start() : JY5113.h
  • JY5113_DI_Stop() : JY5113.h
  • JY5113_DI_TriggerType : JY5113.h
  • JY5113_DI_WaitUntilDone() : JY5113.h
  • JY5113_DigitalTriggerEdge : JY5113.h
  • JY5113_DigitalTriggerSource : JY5113.h
  • JY5113_DisableAICalibration() : JY5113.h
  • JY5113_DisableAOCalibration() : JY5113.h
  • JY5113_DisconnectSignalRouting() : JY5113.h
  • JY5113_DO_AddLines() : JY5113.h
  • JY5113_DO_CheckBufferStatus() : JY5113.h
  • JY5113_DO_ContinuousNoWrapping : JY5113.h
  • JY5113_DO_ContinuousWrapping : JY5113.h
  • JY5113_DO_Digital : JY5113.h
  • JY5113_DO_Finite : JY5113.h
  • JY5113_DO_Immediately : JY5113.h
  • JY5113_DO_SampleClock_Input : JY5113.h
  • JY5113_DO_SendSoftTrigger() : JY5113.h
  • JY5113_DO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_DO_SetMode() : JY5113.h
  • JY5113_DO_SetOutputCompleteState() : JY5113.h
  • JY5113_DO_SetSampleClock() : JY5113.h
  • JY5113_DO_SetSamplesToUpdate() : JY5113.h
  • JY5113_DO_SetStartTriggerType() : JY5113.h
  • JY5113_DO_SetUpdateRate() : JY5113.h
  • JY5113_DO_Single : JY5113.h
  • JY5113_DO_Soft : JY5113.h
  • JY5113_DO_Start() : JY5113.h
  • JY5113_DO_Stop() : JY5113.h
  • JY5113_DO_TriggerType : JY5113.h
  • JY5113_DO_UpdateMode : JY5113.h
  • JY5113_DO_WaitUntilDone() : JY5113.h
  • JY5113_DO_WriteData() : JY5113.h
  • JY5113_DO_WriteSinglePoint() : JY5113.h
  • JY5113_DO_WriteSinglePoint_U16() : JY5113.h
  • JY5113_Entering : JY5113.h
  • JY5113_External_Timebase : JY5113.h
  • JY5113_ExternalClock : JY5113.h
  • JY5113_ExternalClockTerminal : JY5113.h
  • JY5113_Falling : JY5113.h
  • JY5113_FallingEdge : JY5113.h
  • JY5113_FallingSlope : JY5113.h
  • JY5113_GetDeviceID() : JY5113.h
  • JY5113_GetDeviceSerialNumber() : JY5113.h
  • JY5113_HighLevel : JY5113.h
  • JY5113_Hold : JY5113.h
  • JY5113_Independent : JY5113.h
  • JY5113_InputTerminal : JY5113.h
  • JY5113_Inter_AI_ReferenceTrig : JY5113.h
  • JY5113_Inter_AI_StartTrig : JY5113.h
  • JY5113_Inter_AO_StartTrig : JY5113.h
  • JY5113_Inter_Counter_0_Out : JY5113.h
  • JY5113_Inter_Counter_0_StartTrig : JY5113.h
  • JY5113_Inter_Counter_13_Out : JY5113.h
  • JY5113_Inter_Counter_1_Out : JY5113.h
  • JY5113_Inter_Counter_1_StartTrig : JY5113.h
  • JY5113_Inter_Counter_2_Out : JY5113.h
  • JY5113_Inter_Counter_2_StartTrig : JY5113.h
  • JY5113_Inter_Counter_3_StartTrig : JY5113.h
  • JY5113_Inter_DI_ReferenceTrig : JY5113.h
  • JY5113_Inter_DI_StartTrig : JY5113.h
  • JY5113_Inter_DO_StartTrig : JY5113.h
  • JY5113_Internal : JY5113.h
  • JY5113_Internal_Timebase_100K : JY5113.h
  • JY5113_Internal_Timebase_100M : JY5113.h
  • JY5113_Internal_Timebase_5M : JY5113.h
  • JY5113_InternalClock : JY5113.h
  • JY5113_Leaving : JY5113.h
  • JY5113_LevelState : JY5113.h
  • JY5113_LowLevel : JY5113.h
  • JY5113_MASTER : JY5113.h
  • JY5113_None : JY5113.h
  • JY5113_Open() : JY5113.h
  • JY5113_OpenByName() : JY5113.h
  • JY5113_OutputCompleteState : JY5113.h
  • JY5113_PFI0 : JY5113.h
  • JY5113_PFI0_Input : JY5113.h
  • JY5113_PFI0_OUT : JY5113.h
  • JY5113_PFI1 : JY5113.h
  • JY5113_PFI10 : JY5113.h
  • JY5113_PFI10_Input : JY5113.h
  • JY5113_PFI10_OUT : JY5113.h
  • JY5113_PFI11 : JY5113.h
  • JY5113_PFI11_Input : JY5113.h
  • JY5113_PFI11_OUT : JY5113.h
  • JY5113_PFI12 : JY5113.h
  • JY5113_PFI12_Input : JY5113.h
  • JY5113_PFI12_OUT : JY5113.h
  • JY5113_PFI13 : JY5113.h
  • JY5113_PFI13_Input : JY5113.h
  • JY5113_PFI13_OUT : JY5113.h
  • JY5113_PFI14 : JY5113.h
  • JY5113_PFI14_Input : JY5113.h
  • JY5113_PFI14_OUT : JY5113.h
  • JY5113_PFI15 : JY5113.h
  • JY5113_PFI15_Input : JY5113.h
  • JY5113_PFI15_OUT : JY5113.h
  • JY5113_PFI1_Input : JY5113.h
  • JY5113_PFI1_OUT : JY5113.h
  • JY5113_PFI2 : JY5113.h
  • JY5113_PFI2_Input : JY5113.h
  • JY5113_PFI2_OUT : JY5113.h
  • JY5113_PFI3 : JY5113.h
  • JY5113_PFI3_Input : JY5113.h
  • JY5113_PFI3_OUT : JY5113.h
  • JY5113_PFI4 : JY5113.h
  • JY5113_PFI4_Input : JY5113.h
  • JY5113_PFI4_OUT : JY5113.h
  • JY5113_PFI5 : JY5113.h
  • JY5113_PFI5_Input : JY5113.h
  • JY5113_PFI5_OUT : JY5113.h
  • JY5113_PFI6 : JY5113.h
  • JY5113_PFI6_Input : JY5113.h
  • JY5113_PFI6_OUT : JY5113.h
  • JY5113_PFI7 : JY5113.h
  • JY5113_PFI7_Input : JY5113.h
  • JY5113_PFI7_OUT : JY5113.h
  • JY5113_PFI8 : JY5113.h
  • JY5113_PFI8_Input : JY5113.h
  • JY5113_PFI8_OUT : JY5113.h
  • JY5113_PFI9 : JY5113.h
  • JY5113_PFI9_Input : JY5113.h
  • JY5113_PFI9_OUT : JY5113.h
  • JY5113_PXI_Trig0 : JY5113.h
  • JY5113_PXI_Trig0_Input : JY5113.h
  • JY5113_PXI_Trig1 : JY5113.h
  • JY5113_PXI_Trig1_Input : JY5113.h
  • JY5113_PXI_Trig2 : JY5113.h
  • JY5113_PXI_Trig2_Input : JY5113.h
  • JY5113_PXI_Trig3 : JY5113.h
  • JY5113_PXI_Trig3_Input : JY5113.h
  • JY5113_PXI_Trig4 : JY5113.h
  • JY5113_PXI_Trig4_Input : JY5113.h
  • JY5113_PXI_Trig5 : JY5113.h
  • JY5113_PXI_Trig5_Input : JY5113.h
  • JY5113_PXI_Trig6 : JY5113.h
  • JY5113_PXI_Trig6_Input : JY5113.h
  • JY5113_PXI_Trig7 : JY5113.h
  • JY5113_PXI_Trig7_Input : JY5113.h
  • JY5113_PXIe_Clk100 : JY5113.h
  • JY5113_PXITrig0_OUT : JY5113.h
  • JY5113_PXITrig1_OUT : JY5113.h
  • JY5113_PXITrig2_OUT : JY5113.h
  • JY5113_PXITrig3_OUT : JY5113.h
  • JY5113_PXITrig4_OUT : JY5113.h
  • JY5113_PXITrig5_OUT : JY5113.h
  • JY5113_PXITrig6_OUT : JY5113.h
  • JY5113_PXITrig7_OUT : JY5113.h
  • JY5113_ReferenceClock : JY5113.h
  • JY5113_ReferenceTrigger : JY5113.h
  • JY5113_Rising : JY5113.h
  • JY5113_RisingEdge : JY5113.h
  • JY5113_RisingSlope : JY5113.h
  • JY5113_SetDeviceReferenceClock() : JY5113.h
  • JY5113_SetDeviceStatusLed() : JY5113.h
  • JY5113_SetPFIFilter() : JY5113.h
  • JY5113_Signal_AI_ReferenceTrig : JY5113.h
  • JY5113_Signal_AI_SampleClock : JY5113.h
  • JY5113_Signal_AI_StartTrig : JY5113.h
  • JY5113_Signal_AO_SampleClock : JY5113.h
  • JY5113_Signal_AO_StartTrig : JY5113.h
  • JY5113_Signal_CI_0_SampleClock : JY5113.h
  • JY5113_Signal_CI_1_SampleClock : JY5113.h
  • JY5113_Signal_CI_2_SampleClock : JY5113.h
  • JY5113_Signal_CI_3_SampleClock : JY5113.h
  • JY5113_Signal_CIO_0_StartTrig : JY5113.h
  • JY5113_Signal_CIO_100kHz : JY5113.h
  • JY5113_Signal_CIO_100MHz : JY5113.h
  • JY5113_Signal_CIO_1_StartTrig : JY5113.h
  • JY5113_Signal_CIO_2_StartTrig : JY5113.h
  • JY5113_Signal_CIO_3_StartTrig : JY5113.h
  • JY5113_Signal_CIO_5MHz : JY5113.h
  • JY5113_Signal_CO_0_Output : JY5113.h
  • JY5113_Signal_CO_1_Output : JY5113.h
  • JY5113_Signal_CO_2_Output : JY5113.h
  • JY5113_Signal_CO_3_Output : JY5113.h
  • JY5113_Signal_Destination : JY5113.h
  • JY5113_Signal_DI_ReferenceTrig : JY5113.h
  • JY5113_Signal_DI_SampleClock : JY5113.h
  • JY5113_Signal_DI_StartTrig : JY5113.h
  • JY5113_Signal_DO_SampleClock : JY5113.h
  • JY5113_Signal_DO_StartTrig : JY5113.h
  • JY5113_Signal_PFI_0 : JY5113.h
  • JY5113_Signal_PFI_1 : JY5113.h
  • JY5113_Signal_PFI_10 : JY5113.h
  • JY5113_Signal_PFI_11 : JY5113.h
  • JY5113_Signal_PFI_12 : JY5113.h
  • JY5113_Signal_PFI_13 : JY5113.h
  • JY5113_Signal_PFI_14 : JY5113.h
  • JY5113_Signal_PFI_15 : JY5113.h
  • JY5113_Signal_PFI_2 : JY5113.h
  • JY5113_Signal_PFI_3 : JY5113.h
  • JY5113_Signal_PFI_4 : JY5113.h
  • JY5113_Signal_PFI_5 : JY5113.h
  • JY5113_Signal_PFI_6 : JY5113.h
  • JY5113_Signal_PFI_7 : JY5113.h
  • JY5113_Signal_PFI_8 : JY5113.h
  • JY5113_Signal_PFI_9 : JY5113.h
  • JY5113_Signal_PXI_Trig_0 : JY5113.h
  • JY5113_Signal_PXI_Trig_1 : JY5113.h
  • JY5113_Signal_PXI_Trig_2 : JY5113.h
  • JY5113_Signal_PXI_Trig_3 : JY5113.h
  • JY5113_Signal_PXI_Trig_4 : JY5113.h
  • JY5113_Signal_PXI_Trig_5 : JY5113.h
  • JY5113_Signal_PXI_Trig_6 : JY5113.h
  • JY5113_Signal_PXI_Trig_7 : JY5113.h
  • JY5113_Signal_Source : JY5113.h
  • JY5113_SignalRouting() : JY5113.h
  • JY5113_SLAVE : JY5113.h
  • JY5113_StartTrigger : JY5113.h
  • JY5113_TriggerMode : JY5113.h
  • JY5113_TriggerType : JY5113.h
  • JY5113_Zero : JY5113.h


- j -

  • JY5113_AI_BandWidth : JY5113.h
  • JY5113_AI_SampleMode : JY5113.h
  • JY5113_AI_Terminal : JY5113.h
  • JY5113_AI_TriggerType : JY5113.h
  • JY5113_AnalogTriggerEdge : JY5113.h
  • JY5113_AnalogTriggerSource : JY5113.h
  • JY5113_AnalogWindowCondition : JY5113.h
  • JY5113_AO_UpdateMode : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState : JY5113.h
  • JY5113_CI_MeasureType : JY5113.h
  • JY5113_CI_SampleClock : JY5113.h
  • JY5113_CI_SampleMode : JY5113.h
  • JY5113_CI_StartingEdge : JY5113.h
  • JY5113_CI_ValueReturnMode : JY5113.h
  • JY5113_CIO_TriggerType : JY5113.h
  • JY5113_ClockSource : JY5113.h
  • JY5113_CO_IdleState : JY5113.h
  • JY5113_CO_OUTMode : JY5113.h
  • JY5113_CountDirection : JY5113.h
  • JY5113_CountTimeBase : JY5113.h
  • JY5113_DeviceProperty : JY5113.h
  • JY5113_DI_SampleMode : JY5113.h
  • JY5113_DI_TriggerType : JY5113.h
  • JY5113_DigitalTriggerEdge : JY5113.h
  • JY5113_DigitalTriggerSource : JY5113.h
  • JY5113_DO_TriggerType : JY5113.h
  • JY5113_DO_UpdateMode : JY5113.h
  • JY5113_ExternalClockTerminal : JY5113.h
  • JY5113_InputTerminal : JY5113.h
  • JY5113_LevelState : JY5113.h
  • JY5113_OutputCompleteState : JY5113.h
  • JY5113_ReferenceClock : JY5113.h
  • JY5113_Signal_Destination : JY5113.h
  • JY5113_Signal_Source : JY5113.h
  • JY5113_TriggerMode : JY5113.h
  • JY5113_TriggerType : JY5113.h


- j -

  • JY5113_AI_Analog : JY5113.h
  • JY5113_AI_BandWidth_15K : JY5113.h
  • JY5113_AI_BandWidth_39K : JY5113.h
  • JY5113_AI_BandWidth_80K : JY5113.h
  • JY5113_AI_Continuous : JY5113.h
  • JY5113_AI_Diff : JY5113.h
  • JY5113_AI_Digital : JY5113.h
  • JY5113_AI_Finite : JY5113.h
  • JY5113_AI_Immediately : JY5113.h
  • JY5113_AI_RSE : JY5113.h
  • JY5113_AI_SampleClock_Input : JY5113.h
  • JY5113_AI_Single : JY5113.h
  • JY5113_AI_Soft : JY5113.h
  • JY5113_AnyEdge : JY5113.h
  • JY5113_AO_ContinuousNoWrapping : JY5113.h
  • JY5113_AO_ContinuousWrapping : JY5113.h
  • JY5113_AO_Digital : JY5113.h
  • JY5113_AO_Finite : JY5113.h
  • JY5113_AO_Immediately : JY5113.h
  • JY5113_AO_SampleClock_Input : JY5113.h
  • JY5113_AO_Single : JY5113.h
  • JY5113_AO_Soft : JY5113.h
  • JY5113_Channel_0 : JY5113.h
  • JY5113_Channel_1 : JY5113.h
  • JY5113_Channel_10 : JY5113.h
  • JY5113_Channel_11 : JY5113.h
  • JY5113_Channel_12 : JY5113.h
  • JY5113_Channel_13 : JY5113.h
  • JY5113_Channel_14 : JY5113.h
  • JY5113_Channel_15 : JY5113.h
  • JY5113_Channel_16 : JY5113.h
  • JY5113_Channel_17 : JY5113.h
  • JY5113_Channel_18 : JY5113.h
  • JY5113_Channel_19 : JY5113.h
  • JY5113_Channel_2 : JY5113.h
  • JY5113_Channel_20 : JY5113.h
  • JY5113_Channel_21 : JY5113.h
  • JY5113_Channel_22 : JY5113.h
  • JY5113_Channel_23 : JY5113.h
  • JY5113_Channel_24 : JY5113.h
  • JY5113_Channel_25 : JY5113.h
  • JY5113_Channel_26 : JY5113.h
  • JY5113_Channel_27 : JY5113.h
  • JY5113_Channel_28 : JY5113.h
  • JY5113_Channel_29 : JY5113.h
  • JY5113_Channel_3 : JY5113.h
  • JY5113_Channel_30 : JY5113.h
  • JY5113_Channel_31 : JY5113.h
  • JY5113_Channel_32 : JY5113.h
  • JY5113_Channel_33 : JY5113.h
  • JY5113_Channel_34 : JY5113.h
  • JY5113_Channel_35 : JY5113.h
  • JY5113_Channel_36 : JY5113.h
  • JY5113_Channel_37 : JY5113.h
  • JY5113_Channel_38 : JY5113.h
  • JY5113_Channel_39 : JY5113.h
  • JY5113_Channel_4 : JY5113.h
  • JY5113_Channel_40 : JY5113.h
  • JY5113_Channel_41 : JY5113.h
  • JY5113_Channel_42 : JY5113.h
  • JY5113_Channel_43 : JY5113.h
  • JY5113_Channel_44 : JY5113.h
  • JY5113_Channel_45 : JY5113.h
  • JY5113_Channel_46 : JY5113.h
  • JY5113_Channel_47 : JY5113.h
  • JY5113_Channel_48 : JY5113.h
  • JY5113_Channel_49 : JY5113.h
  • JY5113_Channel_5 : JY5113.h
  • JY5113_Channel_50 : JY5113.h
  • JY5113_Channel_51 : JY5113.h
  • JY5113_Channel_52 : JY5113.h
  • JY5113_Channel_53 : JY5113.h
  • JY5113_Channel_54 : JY5113.h
  • JY5113_Channel_55 : JY5113.h
  • JY5113_Channel_56 : JY5113.h
  • JY5113_Channel_57 : JY5113.h
  • JY5113_Channel_58 : JY5113.h
  • JY5113_Channel_59 : JY5113.h
  • JY5113_Channel_6 : JY5113.h
  • JY5113_Channel_60 : JY5113.h
  • JY5113_Channel_61 : JY5113.h
  • JY5113_Channel_62 : JY5113.h
  • JY5113_Channel_63 : JY5113.h
  • JY5113_Channel_7 : JY5113.h
  • JY5113_Channel_8 : JY5113.h
  • JY5113_Channel_9 : JY5113.h
  • JY5113_CI_Continuous : JY5113.h
  • JY5113_CI_Count_Down : JY5113.h
  • JY5113_CI_Count_External : JY5113.h
  • JY5113_CI_Count_Up : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState_High : JY5113.h
  • JY5113_CI_CounterEventSignalIdleState_Low : JY5113.h
  • JY5113_CI_EdgeCount : JY5113.h
  • JY5113_CI_EncoderTwoPulse : JY5113.h
  • JY5113_CI_EncoderX1 : JY5113.h
  • JY5113_CI_EncoderX2 : JY5113.h
  • JY5113_CI_EncoderX4 : JY5113.h
  • JY5113_CI_ExternalClock : JY5113.h
  • JY5113_CI_Finite : JY5113.h
  • JY5113_CI_ImplicitClock : JY5113.h
  • JY5113_CI_InternalClock : JY5113.h
  • JY5113_CI_Measure_EdgeSeparation : JY5113.h
  • JY5113_CI_Measure_FrequencyOrPeriod : JY5113.h
  • JY5113_CI_Measure_PulseWidth : JY5113.h
  • JY5113_CI_Measure_SemiPeriod : JY5113.h
  • JY5113_CI_ReturnOneValue : JY5113.h
  • JY5113_CI_ReturnTwoValue : JY5113.h
  • JY5113_CI_Single : JY5113.h
  • JY5113_CIO_100kHz_Input : JY5113.h
  • JY5113_CIO_100MHz_Input : JY5113.h
  • JY5113_CIO_5MHz_Input : JY5113.h
  • JY5113_CIO_Digital : JY5113.h
  • JY5113_CIO_Immediately : JY5113.h
  • JY5113_CIO_Soft : JY5113.h
  • JY5113_Clock_AI_SampleClock : JY5113.h
  • JY5113_Clock_AO_SampleClock : JY5113.h
  • JY5113_Clock_CI_0_SampleClock : JY5113.h
  • JY5113_Clock_CI_1_SampleClock : JY5113.h
  • JY5113_Clock_CI_2_SampleClock : JY5113.h
  • JY5113_Clock_CI_3_SampleClock : JY5113.h
  • JY5113_Clock_CO_0_Output : JY5113.h
  • JY5113_Clock_CO_1_Output : JY5113.h
  • JY5113_Clock_CO_2_Output : JY5113.h
  • JY5113_Clock_CO_3_Output : JY5113.h
  • JY5113_Clock_DI_SampleClock : JY5113.h
  • JY5113_Clock_DO_SampleClock : JY5113.h
  • JY5113_Clock_PFI_0 : JY5113.h
  • JY5113_Clock_PFI_1 : JY5113.h
  • JY5113_Clock_PFI_10 : JY5113.h
  • JY5113_Clock_PFI_11 : JY5113.h
  • JY5113_Clock_PFI_12 : JY5113.h
  • JY5113_Clock_PFI_13 : JY5113.h
  • JY5113_Clock_PFI_14 : JY5113.h
  • JY5113_Clock_PFI_15 : JY5113.h
  • JY5113_Clock_PFI_2 : JY5113.h
  • JY5113_Clock_PFI_3 : JY5113.h
  • JY5113_Clock_PFI_4 : JY5113.h
  • JY5113_Clock_PFI_5 : JY5113.h
  • JY5113_Clock_PFI_6 : JY5113.h
  • JY5113_Clock_PFI_7 : JY5113.h
  • JY5113_Clock_PFI_8 : JY5113.h
  • JY5113_Clock_PFI_9 : JY5113.h
  • JY5113_Clock_PXI_Trig_0 : JY5113.h
  • JY5113_Clock_PXI_Trig_1 : JY5113.h
  • JY5113_Clock_PXI_Trig_2 : JY5113.h
  • JY5113_Clock_PXI_Trig_3 : JY5113.h
  • JY5113_Clock_PXI_Trig_4 : JY5113.h
  • JY5113_Clock_PXI_Trig_5 : JY5113.h
  • JY5113_Clock_PXI_Trig_6 : JY5113.h
  • JY5113_Clock_PXI_Trig_7 : JY5113.h
  • JY5113_CO_0_Output_Input : JY5113.h
  • JY5113_CO_1_Output_Input : JY5113.h
  • JY5113_CO_2_Output_Input : JY5113.h
  • JY5113_CO_3_Output_Input : JY5113.h
  • JY5113_CO_ContinuousNoWrapping : JY5113.h
  • JY5113_CO_ContinuousWrapping : JY5113.h
  • JY5113_CO_Finite : JY5113.h
  • JY5113_CO_HighLevel : JY5113.h
  • JY5113_CO_LowLevel : JY5113.h
  • JY5113_CO_Single : JY5113.h
  • JY5113_DI_Continuous : JY5113.h
  • JY5113_DI_Digital : JY5113.h
  • JY5113_DI_Finite : JY5113.h
  • JY5113_DI_Immediately : JY5113.h
  • JY5113_DI_SampleClock_Input : JY5113.h
  • JY5113_DI_Single : JY5113.h
  • JY5113_DI_Soft : JY5113.h
  • JY5113_DO_ContinuousNoWrapping : JY5113.h
  • JY5113_DO_ContinuousWrapping : JY5113.h
  • JY5113_DO_Digital : JY5113.h
  • JY5113_DO_Finite : JY5113.h
  • JY5113_DO_Immediately : JY5113.h
  • JY5113_DO_SampleClock_Input : JY5113.h
  • JY5113_DO_Single : JY5113.h
  • JY5113_DO_Soft : JY5113.h
  • JY5113_Entering : JY5113.h
  • JY5113_External_Timebase : JY5113.h
  • JY5113_ExternalClock : JY5113.h
  • JY5113_Falling : JY5113.h
  • JY5113_FallingEdge : JY5113.h
  • JY5113_FallingSlope : JY5113.h
  • JY5113_HighLevel : JY5113.h
  • JY5113_Hold : JY5113.h
  • JY5113_Independent : JY5113.h
  • JY5113_Inter_AI_ReferenceTrig : JY5113.h
  • JY5113_Inter_AI_StartTrig : JY5113.h
  • JY5113_Inter_AO_StartTrig : JY5113.h
  • JY5113_Inter_Counter_0_Out : JY5113.h
  • JY5113_Inter_Counter_0_StartTrig : JY5113.h
  • JY5113_Inter_Counter_13_Out : JY5113.h
  • JY5113_Inter_Counter_1_Out : JY5113.h
  • JY5113_Inter_Counter_1_StartTrig : JY5113.h
  • JY5113_Inter_Counter_2_Out : JY5113.h
  • JY5113_Inter_Counter_2_StartTrig : JY5113.h
  • JY5113_Inter_Counter_3_StartTrig : JY5113.h
  • JY5113_Inter_DI_ReferenceTrig : JY5113.h
  • JY5113_Inter_DI_StartTrig : JY5113.h
  • JY5113_Inter_DO_StartTrig : JY5113.h
  • JY5113_Internal : JY5113.h
  • JY5113_Internal_Timebase_100K : JY5113.h
  • JY5113_Internal_Timebase_100M : JY5113.h
  • JY5113_Internal_Timebase_5M : JY5113.h
  • JY5113_InternalClock : JY5113.h
  • JY5113_Leaving : JY5113.h
  • JY5113_LowLevel : JY5113.h
  • JY5113_MASTER : JY5113.h
  • JY5113_None : JY5113.h
  • JY5113_PFI0 : JY5113.h
  • JY5113_PFI0_Input : JY5113.h
  • JY5113_PFI0_OUT : JY5113.h
  • JY5113_PFI1 : JY5113.h
  • JY5113_PFI10 : JY5113.h
  • JY5113_PFI10_Input : JY5113.h
  • JY5113_PFI10_OUT : JY5113.h
  • JY5113_PFI11 : JY5113.h
  • JY5113_PFI11_Input : JY5113.h
  • JY5113_PFI11_OUT : JY5113.h
  • JY5113_PFI12 : JY5113.h
  • JY5113_PFI12_Input : JY5113.h
  • JY5113_PFI12_OUT : JY5113.h
  • JY5113_PFI13 : JY5113.h
  • JY5113_PFI13_Input : JY5113.h
  • JY5113_PFI13_OUT : JY5113.h
  • JY5113_PFI14 : JY5113.h
  • JY5113_PFI14_Input : JY5113.h
  • JY5113_PFI14_OUT : JY5113.h
  • JY5113_PFI15 : JY5113.h
  • JY5113_PFI15_Input : JY5113.h
  • JY5113_PFI15_OUT : JY5113.h
  • JY5113_PFI1_Input : JY5113.h
  • JY5113_PFI1_OUT : JY5113.h
  • JY5113_PFI2 : JY5113.h
  • JY5113_PFI2_Input : JY5113.h
  • JY5113_PFI2_OUT : JY5113.h
  • JY5113_PFI3 : JY5113.h
  • JY5113_PFI3_Input : JY5113.h
  • JY5113_PFI3_OUT : JY5113.h
  • JY5113_PFI4 : JY5113.h
  • JY5113_PFI4_Input : JY5113.h
  • JY5113_PFI4_OUT : JY5113.h
  • JY5113_PFI5 : JY5113.h
  • JY5113_PFI5_Input : JY5113.h
  • JY5113_PFI5_OUT : JY5113.h
  • JY5113_PFI6 : JY5113.h
  • JY5113_PFI6_Input : JY5113.h
  • JY5113_PFI6_OUT : JY5113.h
  • JY5113_PFI7 : JY5113.h
  • JY5113_PFI7_Input : JY5113.h
  • JY5113_PFI7_OUT : JY5113.h
  • JY5113_PFI8 : JY5113.h
  • JY5113_PFI8_Input : JY5113.h
  • JY5113_PFI8_OUT : JY5113.h
  • JY5113_PFI9 : JY5113.h
  • JY5113_PFI9_Input : JY5113.h
  • JY5113_PFI9_OUT : JY5113.h
  • JY5113_PXI_Trig0 : JY5113.h
  • JY5113_PXI_Trig0_Input : JY5113.h
  • JY5113_PXI_Trig1 : JY5113.h
  • JY5113_PXI_Trig1_Input : JY5113.h
  • JY5113_PXI_Trig2 : JY5113.h
  • JY5113_PXI_Trig2_Input : JY5113.h
  • JY5113_PXI_Trig3 : JY5113.h
  • JY5113_PXI_Trig3_Input : JY5113.h
  • JY5113_PXI_Trig4 : JY5113.h
  • JY5113_PXI_Trig4_Input : JY5113.h
  • JY5113_PXI_Trig5 : JY5113.h
  • JY5113_PXI_Trig5_Input : JY5113.h
  • JY5113_PXI_Trig6 : JY5113.h
  • JY5113_PXI_Trig6_Input : JY5113.h
  • JY5113_PXI_Trig7 : JY5113.h
  • JY5113_PXI_Trig7_Input : JY5113.h
  • JY5113_PXIe_Clk100 : JY5113.h
  • JY5113_PXITrig0_OUT : JY5113.h
  • JY5113_PXITrig1_OUT : JY5113.h
  • JY5113_PXITrig2_OUT : JY5113.h
  • JY5113_PXITrig3_OUT : JY5113.h
  • JY5113_PXITrig4_OUT : JY5113.h
  • JY5113_PXITrig5_OUT : JY5113.h
  • JY5113_PXITrig6_OUT : JY5113.h
  • JY5113_PXITrig7_OUT : JY5113.h
  • JY5113_ReferenceTrigger : JY5113.h
  • JY5113_Rising : JY5113.h
  • JY5113_RisingEdge : JY5113.h
  • JY5113_RisingSlope : JY5113.h
  • JY5113_Signal_AI_ReferenceTrig : JY5113.h
  • JY5113_Signal_AI_SampleClock : JY5113.h
  • JY5113_Signal_AI_StartTrig : JY5113.h
  • JY5113_Signal_AO_SampleClock : JY5113.h
  • JY5113_Signal_AO_StartTrig : JY5113.h
  • JY5113_Signal_CI_0_SampleClock : JY5113.h
  • JY5113_Signal_CI_1_SampleClock : JY5113.h
  • JY5113_Signal_CI_2_SampleClock : JY5113.h
  • JY5113_Signal_CI_3_SampleClock : JY5113.h
  • JY5113_Signal_CIO_0_StartTrig : JY5113.h
  • JY5113_Signal_CIO_100kHz : JY5113.h
  • JY5113_Signal_CIO_100MHz : JY5113.h
  • JY5113_Signal_CIO_1_StartTrig : JY5113.h
  • JY5113_Signal_CIO_2_StartTrig : JY5113.h
  • JY5113_Signal_CIO_3_StartTrig : JY5113.h
  • JY5113_Signal_CIO_5MHz : JY5113.h
  • JY5113_Signal_CO_0_Output : JY5113.h
  • JY5113_Signal_CO_1_Output : JY5113.h
  • JY5113_Signal_CO_2_Output : JY5113.h
  • JY5113_Signal_CO_3_Output : JY5113.h
  • JY5113_Signal_DI_ReferenceTrig : JY5113.h
  • JY5113_Signal_DI_SampleClock : JY5113.h
  • JY5113_Signal_DI_StartTrig : JY5113.h
  • JY5113_Signal_DO_SampleClock : JY5113.h
  • JY5113_Signal_DO_StartTrig : JY5113.h
  • JY5113_Signal_PFI_0 : JY5113.h
  • JY5113_Signal_PFI_1 : JY5113.h
  • JY5113_Signal_PFI_10 : JY5113.h
  • JY5113_Signal_PFI_11 : JY5113.h
  • JY5113_Signal_PFI_12 : JY5113.h
  • JY5113_Signal_PFI_13 : JY5113.h
  • JY5113_Signal_PFI_14 : JY5113.h
  • JY5113_Signal_PFI_15 : JY5113.h
  • JY5113_Signal_PFI_2 : JY5113.h
  • JY5113_Signal_PFI_3 : JY5113.h
  • JY5113_Signal_PFI_4 : JY5113.h
  • JY5113_Signal_PFI_5 : JY5113.h
  • JY5113_Signal_PFI_6 : JY5113.h
  • JY5113_Signal_PFI_7 : JY5113.h
  • JY5113_Signal_PFI_8 : JY5113.h
  • JY5113_Signal_PFI_9 : JY5113.h
  • JY5113_Signal_PXI_Trig_0 : JY5113.h
  • JY5113_Signal_PXI_Trig_1 : JY5113.h
  • JY5113_Signal_PXI_Trig_2 : JY5113.h
  • JY5113_Signal_PXI_Trig_3 : JY5113.h
  • JY5113_Signal_PXI_Trig_4 : JY5113.h
  • JY5113_Signal_PXI_Trig_5 : JY5113.h
  • JY5113_Signal_PXI_Trig_6 : JY5113.h
  • JY5113_Signal_PXI_Trig_7 : JY5113.h
  • JY5113_SLAVE : JY5113.h
  • JY5113_StartTrigger : JY5113.h
  • JY5113_Zero : JY5113.h


- j -

  • JY5113_AI_CheckBufferStatus() : JY5113.h
  • JY5113_AI_EnableChannel() : JY5113.h
  • JY5113_AI_ReadData() : JY5113.h
  • JY5113_AI_ReadRawData() : JY5113.h
  • JY5113_AI_ReadSinglePoint() : JY5113.h
  • JY5113_AI_SendSoftTrigger() : JY5113.h
  • JY5113_AI_SetAnalogEdgeReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogEdgeStartTrigger() : JY5113.h
  • JY5113_AI_SetAnalogHysteresisReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogHysteresisStartTrigger() : JY5113.h
  • JY5113_AI_SetAnalogWindowReferenceTrigger() : JY5113.h
  • JY5113_AI_SetAnalogWindowStartTrigger() : JY5113.h
  • JY5113_AI_SetDigitalReferenceTrigger() : JY5113.h
  • JY5113_AI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_AI_SetDSMode() : JY5113.h
  • JY5113_AI_SetMode() : JY5113.h
  • JY5113_AI_SetPreTriggerSamples() : JY5113.h
  • JY5113_AI_SetReferenceTriggerType() : JY5113.h
  • JY5113_AI_SetReTriggerCount() : JY5113.h
  • JY5113_AI_SetSampleClock() : JY5113.h
  • JY5113_AI_SetSampleRate() : JY5113.h
  • JY5113_AI_SetSamplesToAcquire() : JY5113.h
  • JY5113_AI_SetStartTriggerType() : JY5113.h
  • JY5113_AI_Start() : JY5113.h
  • JY5113_AI_Stop() : JY5113.h
  • JY5113_AI_WaitUntilDone() : JY5113.h
  • JY5113_AO_CheckBufferStatus() : JY5113.h
  • JY5113_AO_EnableChannel() : JY5113.h
  • JY5113_AO_SendSoftTrigger() : JY5113.h
  • JY5113_AO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_AO_SetMode() : JY5113.h
  • JY5113_AO_SetOutputCompleteState() : JY5113.h
  • JY5113_AO_SetSampleClock() : JY5113.h
  • JY5113_AO_SetSamplesToUpdate() : JY5113.h
  • JY5113_AO_SetStartTriggerType() : JY5113.h
  • JY5113_AO_SetUpdateRate() : JY5113.h
  • JY5113_AO_Start() : JY5113.h
  • JY5113_AO_Stop() : JY5113.h
  • JY5113_AO_WaitUntilDone() : JY5113.h
  • JY5113_AO_WriteData() : JY5113.h
  • JY5113_AO_WriteRawData() : JY5113.h
  • JY5113_AO_WriteRawSinglePoint() : JY5113.h
  • JY5113_AO_WriteSinglePoint() : JY5113.h
  • JY5113_CI_CheckBufferStatus() : JY5113.h
  • JY5113_CI_EnableChannel() : JY5113.h
  • JY5113_CI_ReadCountValues() : JY5113.h
  • JY5113_CI_ReadMeasureValues() : JY5113.h
  • JY5113_CI_ReadSingleCountValue() : JY5113.h
  • JY5113_CI_ReadSingleMeasureValue() : JY5113.h
  • JY5113_CI_SendSoftTrigger() : JY5113.h
  • JY5113_CI_SetAuxTerminal() : JY5113.h
  • JY5113_CI_SetCounterParament() : JY5113.h
  • JY5113_CI_SetCounterType() : JY5113.h
  • JY5113_CI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_CI_SetEdgeCountEvent() : JY5113.h
  • JY5113_CI_SetFirstSampleClock() : JY5113.h
  • JY5113_CI_SetGateTerminal() : JY5113.h
  • JY5113_CI_SetMode() : JY5113.h
  • JY5113_CI_SetOutTerminal() : JY5113.h
  • JY5113_CI_SetPauseTriggerLevel() : JY5113.h
  • JY5113_CI_SetPauseTriggerTerminal() : JY5113.h
  • JY5113_CI_SetSampleClock() : JY5113.h
  • JY5113_CI_SetSamplesToAcquire() : JY5113.h
  • JY5113_CI_SetSignalReverse() : JY5113.h
  • JY5113_CI_SetSourceTerminal() : JY5113.h
  • JY5113_CI_SetStartingEdge() : JY5113.h
  • JY5113_CI_SetStartTriggerType() : JY5113.h
  • JY5113_CI_SetTimeBase() : JY5113.h
  • JY5113_CI_SetValueReturnMode() : JY5113.h
  • JY5113_CI_SetZReloadEnabled() : JY5113.h
  • JY5113_CI_Start() : JY5113.h
  • JY5113_CI_Stop() : JY5113.h
  • JY5113_Close() : JY5113.h
  • JY5113_CO_CheckBufferStatus() : JY5113.h
  • JY5113_CO_CheckCounterStatus() : JY5113.h
  • JY5113_CO_EnableChannel() : JY5113.h
  • JY5113_CO_SendSoftTrigger() : JY5113.h
  • JY5113_CO_SetCounterParament() : JY5113.h
  • JY5113_CO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_CO_SetFrequency() : JY5113.h
  • JY5113_CO_SetMode() : JY5113.h
  • JY5113_CO_SetOutTerminal() : JY5113.h
  • JY5113_CO_SetPauseTriggerLevel() : JY5113.h
  • JY5113_CO_SetPauseTriggerTerminal() : JY5113.h
  • JY5113_CO_SetSamplesToUpdate() : JY5113.h
  • JY5113_CO_SetStartTriggerType() : JY5113.h
  • JY5113_CO_SetTimeBase() : JY5113.h
  • JY5113_CO_Start() : JY5113.h
  • JY5113_CO_Stop() : JY5113.h
  • JY5113_CO_WaitUntilDone() : JY5113.h
  • JY5113_CO_WriteData() : JY5113.h
  • JY5113_DI_AddLines() : JY5113.h
  • JY5113_DI_CheckBufferStatus() : JY5113.h
  • JY5113_DI_ReadData() : JY5113.h
  • JY5113_DI_ReadSinglePoint() : JY5113.h
  • JY5113_DI_ReadSinglePoint_U16() : JY5113.h
  • JY5113_DI_SendSoftTrigger() : JY5113.h
  • JY5113_DI_SetDigitalReferenceTrigger() : JY5113.h
  • JY5113_DI_SetDigitalStartTrigger() : JY5113.h
  • JY5113_DI_SetMode() : JY5113.h
  • JY5113_DI_SetPreTriggerSamples() : JY5113.h
  • JY5113_DI_SetReferenceTriggerType() : JY5113.h
  • JY5113_DI_SetSampleClock() : JY5113.h
  • JY5113_DI_SetSampleRate() : JY5113.h
  • JY5113_DI_SetSamplesToAcquire() : JY5113.h
  • JY5113_DI_SetStartTriggerType() : JY5113.h
  • JY5113_DI_Start() : JY5113.h
  • JY5113_DI_Stop() : JY5113.h
  • JY5113_DI_WaitUntilDone() : JY5113.h
  • JY5113_DisableAICalibration() : JY5113.h
  • JY5113_DisableAOCalibration() : JY5113.h
  • JY5113_DisconnectSignalRouting() : JY5113.h
  • JY5113_DO_AddLines() : JY5113.h
  • JY5113_DO_CheckBufferStatus() : JY5113.h
  • JY5113_DO_SendSoftTrigger() : JY5113.h
  • JY5113_DO_SetDigitalStartTrigger() : JY5113.h
  • JY5113_DO_SetMode() : JY5113.h
  • JY5113_DO_SetOutputCompleteState() : JY5113.h
  • JY5113_DO_SetSampleClock() : JY5113.h
  • JY5113_DO_SetSamplesToUpdate() : JY5113.h
  • JY5113_DO_SetStartTriggerType() : JY5113.h
  • JY5113_DO_SetUpdateRate() : JY5113.h
  • JY5113_DO_Start() : JY5113.h
  • JY5113_DO_Stop() : JY5113.h
  • JY5113_DO_WaitUntilDone() : JY5113.h
  • JY5113_DO_WriteData() : JY5113.h
  • JY5113_DO_WriteSinglePoint() : JY5113.h
  • JY5113_DO_WriteSinglePoint_U16() : JY5113.h
  • JY5113_GetDeviceID() : JY5113.h
  • JY5113_GetDeviceSerialNumber() : JY5113.h
  • JY5113_Open() : JY5113.h
  • JY5113_OpenByName() : JY5113.h
  • JY5113_SetDeviceReferenceClock() : JY5113.h
  • JY5113_SetDeviceStatusLed() : JY5113.h
  • JY5113_SetPFIFilter() : JY5113.h
  • JY5113_SignalRouting() : JY5113.h


  • JY5113_DeviceHandle : JY5113.h


5113 C++ Programming Manual: Main Page

5113 C++ Programming Manual Documentation